"yum update python-tripleoclient" fails while following major version upgrade procedure

Solution Verified - Updated -

Issue

  • yum update python-tripleoclient fails while following major version upgrade procedure
$ sudo yum update python-tripleoclient
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
Resolving Dependencies
--> Running transaction check
---> Package python-tripleoclient.noarch 0:2.0.0-14.el7ost will be updated
---> Package python-tripleoclient.noarch 0:5.4.5-1.el7ost will be an update
--> Processing Dependency: python-osc-lib >= 0.3.0 for package: python-tripleoclient-5.4.5-1.el7ost.noarch
--> Processing Dependency: python-mistralclient for package: python-tripleoclient-5.4.5-1.el7ost.noarch
--> Processing Dependency: python-websocket-client for package: python-tripleoclient-5.4.5-1.el7ost.noarch
--> Running transaction check
---> Package python-mistralclient.noarch 0:2.1.2-1.el7ost will be installed
---> Package python-osc-lib.noarch 0:1.1.0-4.el7ost will be installed
--> Processing Dependency: python-keystoneauth1 >= 2.10.0 for package: python-osc-lib-1.1.0-4.el7ost.noarch
--> Processing Dependency: python-oslo-utils >= 3.16.0 for package: python-osc-lib-1.1.0-4.el7ost.noarch
--> Processing Dependency: python-stevedore >= 1.16.0 for package: python-osc-lib-1.1.0-4.el7ost.noarch
---> Package python-tripleoclient.noarch 0:5.4.5-1.el7ost will be an update
--> Processing Dependency: python-websocket-client for package: python-tripleoclient-5.4.5-1.el7ost.noarch
--> Running transaction check
---> Package python-keystoneauth1.noarch 0:2.4.1-1.el7ost will be updated
---> Package python-keystoneauth1.noarch 0:2.12.3-1.el7ost will be an update
---> Package python-oslo-utils.noarch 0:3.7.0-1.el7ost will be updated
---> Package python-oslo-utils.noarch 0:3.16.0-1.el7ost will be an update
--> Processing Dependency: python-oslo-utils-lang = 3.16.0-1.el7ost for package: python-oslo-utils-3.16.0-1.el7ost.noarch
---> Package python-stevedore.noarch 0:1.12.0-1.el7ost will be updated
---> Package python-stevedore.noarch 0:1.17.1-1.el7ost will be an update
---> Package python-tripleoclient.noarch 0:5.4.5-1.el7ost will be an update
--> Processing Dependency: python-websocket-client for package: python-tripleoclient-5.4.5-1.el7ost.noarch
--> Running transaction check
---> Package python-oslo-utils-lang.noarch 0:3.16.0-1.el7ost will be installed
---> Package python-tripleoclient.noarch 0:5.4.5-1.el7ost will be an update
--> Processing Dependency: python-websocket-client for package: python-tripleoclient-5.4.5-1.el7ost.noarch
--> Finished Dependency Resolution
Error: Package: python-tripleoclient-5.4.5-1.el7ost.noarch (rhel-7-server-openstack-10-rpms)
           Requires: python-websocket-client
**********************************************************************
yum can be configured to try to resolve such errors by temporarily enabling
disabled repos and searching for missing dependencies.
To enable this functionality please set 'notify_only=0' in /etc/yum/pluginconf.d/search-disabled-repos.conf
**********************************************************************

Error: Package: python-tripleoclient-5.4.5-1.el7ost.noarch (rhel-7-server-openstack-10-rpms)
           Requires: python-websocket-client
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Environment

  • Red Hat Openstack Platform 9
  • Red Hat Openstack Platform 10
  • Openstack major version upgrade

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In