Satellite 6.x tomcat does not start with server boot

Solution Unverified - Updated -

Issue

  • Tomcat does not start when the server is booted, the below is seen in the logs:
Jun  1 11:02:35 server systemd: Started Apache Tomcat Web Application Container.
Jun  1 11:02:35 server systemd: Starting Apache Tomcat Web Application Container...
Jun  1 11:02:35 server systemd: Failed at step USER spawning /usr/libexec/tomcat/server: No such process
Jun  1 11:02:35 server systemd: Started An AMQP message broker daemon..
Jun  1 11:02:35 server systemd: Starting An AMQP message broker daemon....
Jun  1 11:02:35 server systemd: Started Puppet agent.
Jun  1 11:02:35 server systemd: Starting Puppet agent...
Jun  1 11:02:35 server systemd: Starting The Apache HTTP Server...
Jun  1 11:02:35 server systemd: Started Qpid Dispatch router daemon.
Jun  1 11:02:35 server systemd: Starting Qpid Dispatch router daemon...
Jun  1 11:02:35 server systemd: Started Enable periodic update of entitlement certificates..
Jun  1 11:02:35 server systemd: Started LSB: Starts the Spacewalk Daemon.
Jun  1 11:02:35 server systemd: tomcat.service: main process exited, code=exited, status=217/USER
Jun  1 11:02:35 server systemd: Unit tomcat.service entered failed state.
Jun  1 11:02:35 server systemd: tomcat.service failed.
  • It can be started manually with katello-service restart and systemctl start tomcat.service

Environment

  • Red Hat Enterprise Linux 7.x
  • Red Hat Satellite 6.x

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In