[Satellite 6.2] Hosts are missing from Inventory in Red Hat Insights

Solution In Progress - Updated -

Environment

  • Satellite 6.2+
  • Red Hat Insights clients

Issue

  • Hosts with deployed Red Hat Insight client are missing from Red Hat Insights Inventory in Satellite WebUI

Resolution

Root Cause

  • Satellite renders Red Hat Insights data from the Customer Portal and doesn't store it locally. That data gets stored in a browser cache sometimes and it prevents to visualise reports properly.

Diagnostic Steps

  1. Verify connection to Red Hat Insights by navigating in Satellite WebUI to Insights -> Manage. The status should be 'Connected'.
  2. Login to https://access.redhat.com/insights/ and check if hosts are available in Inventory.
  3. Make sure that the 'Show Satellite systems' option is enabled in Configuration -> Settings on the Insights portal.
  4. If hosts are not available then run 'redhat-access-insights --verbose' to troubleshoot data transfers.

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