[Satellite 6] satellite-installer upgrade fails with error 'Mixing IP and non-IP Listen directives is not possible; check the add_listen parameter of the apache::vhost'

Solution Verified - Updated -

Issue

  • Red Hat Satellite upgrade fails with following error:
[ERROR 2017-03-14 10:48:24 main]  Apache::Vhost[foreman]: Mixing IP and non-IP Listen directives is not possible; check the add_listen parameter of the apache::vhost define to disable this at /usr/share/foreman-installer/modules/apache/manifests/vhost.pp:387 on node Satellite.example.com

Environment

  • Red Hat Satellite 6.2.x

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In