"Cache data unavailable" log messages in a VMWare virtual guest

Solution Verified - Updated -

Environment

  • Red Hat Enterprise Linux 4
  • Red Hat Enterprise Linux 5
  • Red Hat Enterprise Linux 6
  • VMWare

Issue

  • The following messages which may be considered as errors are appearing in the logs ('dmesg' and '/var/log/messages') of a VMWare-virtualized server:
Jan 22 15:24:45 serv02 kernel: sd 2:0:0:0: [sda] Cache data unavailable
Jan 22 15:24:45 serv02 kernel: sd 2:0:0:0: [sda] Cache data unavailable
Jan 22 15:24:45 serv02 kernel: sd 2:0:0:0: [sda] Cache data unavailable

Resolution

  • These messages are harmless and could be safely ignored.

  • Another solution could be installing the latest VMWare Tools on the server. Tools include disk device drivers which are aware that VMWare virtual drives are virtual so they won't log these messages.

Root Cause

  • VMWare virtual drive does not inform the device driver of its caching capabilities. A virtual disk does not have a writeback cache, so the response from the guest operating system is correct. The data can be cached in the server's physical memory and can be lost on a power failure or VMWare host crash if a virtual disk emulates a writeback cache.

Diagnostic Steps

  • Check the system logs for the presence of "Cache data unavailable" entries:
# grep "Cache data unavailable" /var/log/messages
# dmesg | grep "Cache data unavailable"

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