Unable to remove device-mapper-multipath RPM due to mkinitrd dependency

Solution Verified - Updated -

Issue

# rpm -e device-mapper-multipath-0.4.7-54.el5
error: Failed dependencies:
    device-mapper-multipath >= 0.4.7-50 is needed by (installed) mkinitrd-5.1.19.6-79.el5.x86_64
    device-mapper-multipath >= 0.4.7-50 is needed by (installed) mkinitrd-5.1.19.6-79.el5.i386

Environment

  • Red Hat Enterprise Linux 5.9

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In

New to Red Hat?

Learn more about Red Hat subscriptions

Using a Red Hat product through a public cloud?

How to access this content