Can the db_* utilities provided with db4_utils package run on berkely db files used by slapd provided by openldap-servers ?

Solution Verified - Updated -

Issue

  • When running db_archive on Openldap bdb files results in error "Program version 4.3 doesn't match environment version" ?
  • Can the  db_* utilities provided with db4_utils package run on berkely db files used by slapd provided by openldap-servers ?

# cd /var/lib/ldap/
# db_archive
db_archive: Program version 4.3 doesn't match environment version
db_archive: DB_ENV->open: DB_VERSION_MISMATCH: Database environment version mismatch

Environment

  • Red Hat Enterprise Linux Server release 5.4
  • db4-utils-4.3.29-10.el5
  • openldap-2.3.43-3.el5

Subscriber exclusive content

A Red Hat Subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In