Upgrade to Satellite 5.5 fails with slf4j conflict error

Solution Verified - Updated -

Issue

Satellite 5.5 Upgrade fails:

* Starting the Red Hat Network Satellite installer.
* Performing pre-install checks.
* Pre-install checks complete.  Beginning installation.
* RHN Registration.
** Registration: System is already registered with RHN.  Not re-registering.
* Upgrade flag passed.  Stopping necessary services.
* Purging conflicting packages.
* Checking for uninstalled prerequisites.
* Applying updates.
* Installing RHN packages.
Could not install RHN packages.  Most likely your system is not configured with the @Base package group.  See the RHN Satellite Server Installation Guide for more information about Software Requirements.  Exit value: 1.
Please examine /var/log/rhn/rhn_installation.log for more information.

/var/log/rhn/rhn_installation.log shows:

Transaction Check Error:
  file /usr/share/java/slf4j/api.jar from install of slf4j-1.5.8-10_patch_01.2.ep5.el5.noarch conflicts with file from package spacewalk-slf4j-1.6.1-4.el5sat.noarch
  file /usr/share/java/slf4j/jcl.jar from install of slf4j-1.5.8-10_patch_01.2.ep5.el5.noarch conflicts with file from package spacewalk-slf4j-1.6.1-4.el5sat.noarch

Environment

  • Red Hat Network Satellite 5.4
  • Red Hat Enterprise Linux 5

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In