Designate Endpoint does not support RPC

Solution In Progress - Updated -

Issue

  • Designate is constantly reporting following error:
2015-11-16 10:01:19.132 7640 ERROR oslo_messaging.rpc.dispatcher [-] Exception during message handling: Endpoint does not support RPC version 5.2. Attempted method: find_domains
2015-11-16 10:01:19.132 7640 TRACE oslo_messaging.rpc.dispatcher Traceback (most recent call last):
2015-11-16 10:01:19.132 7640 TRACE oslo_messaging.rpc.dispatcher   File "/usr/lib/python2.7/site-packages/oslo_messaging/rpc/dispatcher.py", line 142, in _dispatch_and_reply
2015-11-16 10:01:19.132 7640 TRACE oslo_messaging.rpc.dispatcher     executor_callback))
2015-11-16 10:01:19.132 7640 TRACE oslo_messaging.rpc.dispatcher   File "/usr/lib/python2.7/site-packages/designate/rpc.py", line 178, in _dispatch
2015-11-16 10:01:19.132 7640 TRACE oslo_messaging.rpc.dispatcher     return super(RPCDispatcher, self)._dispatch(*args, **kwds)
2015-11-16 10:01:19.132 7640 TRACE oslo_messaging.rpc.dispatcher   File "/usr/lib/python2.7/site-packages/oslo_messaging/rpc/dispatcher.py", line 195, in _dispatch
2015-11-16 10:01:19.132 7640 TRACE oslo_messaging.rpc.dispatcher     raise UnsupportedVersion(version, method=method)
2015-11-16 10:01:19.132 7640 TRACE oslo_messaging.rpc.dispatcher UnsupportedVersion: Endpoint does not support RPC version 5.2. Attempted method: find_domains
2015-11-16 10:01:19.132 7640 TRACE oslo_messaging.rpc.dispatcher
2015-11-16 10:01:19.135 7640 ERROR oslo_messaging._drivers.common [-] Returning exception Endpoint does not support RPC version 5.2. Attempted method: find_domains to caller
2015-11-16 10:01:19.135 7640 ERROR oslo_messaging._drivers.common [-] ['Traceback (most recent call last):\n', '  File "/usr/lib/python2.7/site-packages/oslo_messaging/rpc/dispatcher.py", line 142, in dispatch_and_reply\n    executor_callback))\n', '  File "/usr/lib/python2.7/site-packages/designate/rpc.py", line 178, in dispatch\n    return super(RPCDispatcher, self)._dispatch(*args, **kwds)\n', '  File "/usr/lib/python2.7/site-packages/oslo_messaging/rpc/dispatcher.py", line 195, in _dispatch\n    raise UnsupportedVersion(version, method=method)\n', 'UnsupportedVersion: Endpoint does not support RPC version 5.2. Attempted method: find_domains\n']
  • Development , one controller and one compute installed using packstack

Environment

  • Red Hat Open Stack

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In