Luci install fails with a python/tkinter missing dependency in RHCS

Solution Verified - Updated -

Issue

Package Luci is part or cluster install.
Package tkinter is required by Luci.
Package python v. 2.4.3-24.el5 is required by tkinter.

[root@ncdap-lod2605 ~]# yum install luci
SNIP
tkinter-2.4.3-24.el5.x86_64 from soe5u3 has depsolving problems
  --> Missing Dependency: python = 2.4.3-24.el5 is needed by package tkinter-2.4.3-24.el5.x86_64 (soe5u3)

yum list shows the correct version:

[root@ncdap-lod2605 tmp]# yum list python
Installed Packages
python.x86_64                                             2.4.3-24.el5_3.6                                  installed
luci.x86_64                                               0.12.1-7.3.el5_3                                             soe5u3
tkinter.x86_64                                            2.4.3-24.el5                                                 soe5u3

Environment

  • Red Hat Enterprise Linux 5.3
  • Red Hat Cluster Suite
  • Customer repo

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In

New to Red Hat?

Learn more about Red Hat subscriptions

Using a Red Hat product through a public cloud?

How to access this content