Can customers replace or upgrade components/libraries of JBoss EAP or SOA-P with different versions?

Solution Verified - Updated -

Issue

  • Can I replace a component/library of JBoss EAP with an older or newer Red Hat library version?
  • Can I upgrade modules in EAP to newer versions to resolve bugs?
  • How can I get the latest version of a community project into EAP?
  • Class loading conflict, loading different versions of the same jar
  • Can we upgrade component/library X?
  • Can we upgrade picketbox to a higher version?

Environment

  • Red Hat JBoss Enterprise Application Platform (EAP)

    • All Releases
  • Red Hat JBoss SOA Platform (SOA-P)

    • All Releases
  • Red Hat JBoss Portal Platform (JPP)

    • All Releases

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In