Why does Red Hat Enterprise Linux 6 fail to update because of `matahari*` packages dependencies errors?

Solution Verified - Updated -

Issue

  • When updating the system to Red Hat Enterprise Linux 6.3 by using yum, yum displays following error and failed to update the system:
Error: Protected multilib versions: matahari-lib-0.4.4-12.el6_2.i686 != matahari-lib-0.6.0-14.el6.x86_64
Error: Protected multilib versions: matahari-agent-lib-0.4.4-12.el6_2.i686 != matahari-agent-lib-0.6.0-14.el6.x86_64
  • Red Hat Enterprise Linux 6 system fails to update because of matahari* packages dependencies.
  • Why the dependencies are not getting resolved ?
  • What are recommendations from Red Hat to update the system ?

Environment

  • Red Hat Enterprise Linux 6
  • matahari packages

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In