OpenStack repository preventing Ceph to be upgraded

Solution In Progress - Updated -

Issue

On a server which is registered to both Ceph and Openstack, yum fails to update to Red Hat Ceph Storage 1.3 (ceph-0.94.1), with the following error (extract only) :

# yum update ceph
[...]
581 packages excluded due to repository priority protections
[...]
--> Finished Dependency Resolution
Error: Package: 1:ceph-0.94.1-16.el7cp.x86_64 (rhel-7-server-rhceph-1.3-mon-rpms)
           Requires: librbd1 = 1:0.94.1
           Installed: 1:librbd1-0.80.8-6.el7cp.x86_64 (@rhel-7-server-rh-common-rpms)
               librbd1 = 1:0.80.8-6.el7cp
           Available: librbd1-0.80.5-1.el7ost.x86_64 (rhel-7-server-openstack-6.0-rpms)
               librbd1 = 0.80.5-1.el7ost
           Available: librbd1-0.80.5-4.el7ost.x86_64 (rhel-7-server-openstack-6.0-rpms)
               librbd1 = 0.80.5-4.el7ost
           Available: 1:librbd1-0.80.7-2.el7.x86_64 (rhel-7-server-rpms)
               librbd1 = 1:0.80.7-2.el7

The machine is correctly registered to the Ceph repos (e.g. : rhel-7-server-rhceph-1.3-mon-rpms for a RHEL7 based Ceph MON)

Environment

  • Red Hat Ceph Storage
  • Server is also registered to OpenStack repositories
  • yum-plugin-priorities installed

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In