Cartridge import with multiple versions for container, fails with undefined method `[]' for nil:NilClass

Solution Unverified - Updated -

Issue

  • I'm trying to create and deploy cartridge with tomcat 7 and 8 support. I have my cartridge based on openshift tomcat cartridge. In this cartridge in manifest yaml file I am used key Version-Overrides however, I'm getting this following output durring installation:
#  oo-admin-cartridge --action install --source ./ca-platformtomcat-1.2.166-20150106.182639-1.zip_dir/ --debug
install failed for /platform/media/cartridges-test-automation/ca-platformtomcat-1.2.166-20150106.182639-1.zip_dir: undefined method `[]' for nil:NilClass
...

Environment

  • OpenShift Enterprise 2.x

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In