[Satellite 6.x] - Cannot install katello-agent on RHEL5 IBM Power ppc64.

Solution Unverified - Updated -

Issue

  • When trying to install the katello-agent package on Red Hat Enterprise Linux 5 IBM Power ppc64 it is failing with the error below:
# yum install katello-agent
Loaded plugins: changelog, downloadonly, filter-data, list-data, product-id, protect-packages, security, subscription-manager, tmprepo, verify
Skipping filters plugin, no data
Setting up Install Process
Resolving Dependencies
Skipping filters plugin, no data
--> Running transaction check
---> Package katello-agent.noarch 0:1.5.3-7.el5sat set to be updated
--> Processing Dependency: python-pulp-agent-lib >= 2.4.0 for package: katello-agent
--> Processing Dependency: python-gofer-qpid >= 1.0.12 for package: katello-agent
--> Processing Dependency: pulp-rpm-handlers >= 2.4.0 for package: katello-agent
--> Processing Dependency: gofer >= 1.0.12 for package: katello-agent
--> Finished Dependency Resolution
katello-agent-1.5.3-7.el5sat.noarch from rhel-5-for-power-rh-common-rpms has depsolving problems
  --> Missing Dependency: gofer >= 1.0.12 is needed by package katello-agent-1.5.3-7.el5sat.noarch (rhel-5-for-power-rh-common-rpms)
katello-agent-1.5.3-7.el5sat.noarch from rhel-5-for-power-rh-common-rpms has depsolving problems
  --> Missing Dependency: python-pulp-agent-lib >= 2.4.0 is needed by package katello-agent-1.5.3-7.el5sat.noarch (rhel-5-for-power-rh-common-rpms)
katello-agent-1.5.3-7.el5sat.noarch from rhel-5-for-power-rh-common-rpms has depsolving problems
  --> Missing Dependency: pulp-rpm-handlers >= 2.4.0 is needed by package katello-agent-1.5.3-7.el5sat.noarch (rhel-5-for-power-rh-common-rpms)
katello-agent-1.5.3-7.el5sat.noarch from rhel-5-for-power-rh-common-rpms has depsolving problems
  --> Missing Dependency: python-gofer-qpid >= 1.0.12 is needed by package katello-agent-1.5.3-7.el5sat.noarch (rhel-5-for-power-rh-common-rpms)
Error: Missing Dependency: python-pulp-agent-lib >= 2.4.0 is needed by package katello-agent-1.5.3-7.el5sat.noarch (rhel-5-for-power-rh-common-rpms)
Error: Missing Dependency: pulp-rpm-handlers >= 2.4.0 is needed by package katello-agent-1.5.3-7.el5sat.noarch (rhel-5-for-power-rh-common-rpms)
Error: Missing Dependency: python-gofer-qpid >= 1.0.12 is needed by package katello-agent-1.5.3-7.el5sat.noarch (rhel-5-for-power-rh-common-rpms)
Error: Missing Dependency: gofer >= 1.0.12 is needed by package katello-agent-1.5.3-7.el5sat.noarch (rhel-5-for-power-rh-common-rpms)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

Environment

  • Red Hat Enterprise Linux 5 for IBM Power

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In