Installation of OpenShift Enterprise 2 fails with a rsyslog7 conflict

Solution In Progress - Updated -

Issue

When installing OpenShift Enterprise 2.1 on Red Hat Enterprise Linux (RHEL) 6.6 via oo-install we are getting the following rsyslog7 conflict:

--> Finished Dependency Resolution
Error: rsyslog7 conflicts with rsyslog-5.8.10-8.el6.x86_64
Error: Package: rsyslog7-mmopenshift-7.4.7-5.7.el6op.x86_64 (rhel-6-server-ose-2.1-node-rpms)
           Requires: rsyslog7 = 7.4.7-5.7.el6op
           Available: rsyslog7-7.4.7-5.4.el6op.x86_64 (rhel-6-server-ose-2.1-node-rpms)
               rsyslog7 = 7.4.7-5.4.el6op
           Available: rsyslog7-7.4.7-5.5.el6op.x86_64 (rhel-6-server-ose-2.1-node-rpms)
               rsyslog7 = 7.4.7-5.5.el6op
           Available: rsyslog7-7.4.7-5.6.el6op.x86_64 (rhel-6-server-ose-2.1-node-rpms)
               rsyslog7 = 7.4.7-5.6.el6op
           Available: rsyslog7-7.4.7-5.7.el6op.x86_64 (rhel-6-server-ose-2.1-node-rpms)
               rsyslog7 = 7.4.7-5.7.el6op
           Installing: rsyslog7-7.4.10-2.el6.x86_64 (rhel-6-server-rpms)
               rsyslog7 = 7.4.10-2.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Environment

  • OpenShift Enterprise (OSE) 2
  • Red Hat Enterprise Linux (RHEL) 6.6

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In