We hit "Protected multilib versions error", when we upgrade an OSE 2.1 install to 2.1.7 or 2.2.9

Solution Verified - Updated -


When I try to update with yum update, I hit following error.

[root@node1 ~]# yum update
Loaded plugins: priorities, product-id, security, subscription-manager
This system is receiving updates from Red Hat Subscription Management.                                                                                                            


--> Finished Dependency Resolution
Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:

         1. You have an upgrade for libcgroup which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of libcgroup of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude libcgroup.otherarch ... this should give you an error
            message showing the root cause of the problem.

         2. You have multiple architectures of libcgroup installed, but
            yum can only see an upgrade for one of those arcitectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.

         3. You have duplicate versions of libcgroup installed already.
            You can use "yum check" to get yum show these errors.

       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).

       Protected multilib versions: libcgroup-0.40.rc1-12.el6.i686 != libcgroup-0.40.rc1-15.el6_6.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
  • Another way this presents its self is like:
--> Processing Dependency: kernel-headers >= 2.2.1 for package: glibc-headers-2.12-1.149.el6.x86_64
--> Processing Dependency: kernel-headers for package: glibc-headers-2.12-1.149.el6.x86_64
--> Running transaction check
---> Package kernel-headers.x86_64 0:2.6.32-504.el6 will be installed
--> Finished Dependency Resolution
  • This happened again when I tried to update 2.2.9.


  • OpenShift Enterprise

    • 2.1.7
    • 2.2.9
  • Red Hat Enterprise Linux

    • 6.6
    • 6.7

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In