Skip to navigation

RHEV-M upgrade fails with error message "rhevm-xxx requires rhevm = 3.2.5-0.49.el6ev"

Updated 2014-03-06T21:40:21+00:00

Issue

  • RHEV-M upgrade from RHEV-M 3.2 to RHEV 3.3 using rhevm-setup fails with the following error message:
[ INFO  ] Checking for product updates...
[ ERROR ] Yum: [u'rhevm-genericapi-3.2.5-0.49.el6ev.noarch requires rhevm = 3.2.5-0.49.el6ev', u'rhevm-notification-service-3.2.5-0.49.el6ev.noarch requires rhevm = 3.2.5-0.49.el6ev', u'rhevm-tools-common-3.2.5-0.49.el6ev.noarch requires rhevm = 3.2.5-0.49.el6ev']
[ INFO  ] Yum: Performing yum transaction rollback
[ ERROR ] Failed to execute stage 'Environment customization': [u'rhevm-genericapi-3.2.5-0.49.el6ev.noarch requires rhevm = 3.2.5-0.49.el6ev', u'rhevm-notification-service-3.2.5-0.49.el6ev.noarch requires rhevm = 3.2.5-0.49.el6ev', u'rhevm-tools-common-3.2.5-0.49.el6ev.noarch requires rhevm = 3.2.5-0.49.el6ev']
[ INFO  ] Stage: Clean up
          Log file is located at /var/log/ovirt-engine/setup/ovirt-engine-setup-20140123142444.log
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Execution of upgrade failed
  • Upgrading RHEV-M 3.2 to version 3.2.5-0.49.el6ev using the following steps also fails.
# rhn-channel --add --channel=rhel-x86_64-server-6-rhevm-3.2
# rhn-channel --remove --channel=rhel-x86_64-server-6-rhevm-3.3
# rhevm-setup
  • This upgrade fails with the following error message, and automatically rolls back to the previous version:
[ ERROR ] Failed to execute stage 'Misc configuration': [Errno 2] No such file or directory

Environment

  • RHEV Manager 3.2.4-0.44.el6ev
    • rhevm-setup-3.3.0-0.45.el6ev.noarch
  • RHEV Manager 3.2.5-0.49.el6ev
    • rhevm-setup-3.3.0-0.49.el6ev.noarch

Subscriber content preview. For full access to the Red Hat Knowledgebase, please log in.

Not a subscriber? Learn more about the benefits of Red Hat Subscriptions.