Skip to navigation

The `yum` command shows an error message `Unable to read consumer identity`

Updated 2013-11-26T01:53:46+00:00

Issue

  • While running the yum update command, we receive the error message Unable to read consumer identity
  • yum install <package> results in a long Python trace which ends with M2Crypto.SSL.SSLError: certificate verify failed

Environment

  • Red Hat Enterprise Linux 6
  • Red Hat Enterprise Linux 5.7 and above
  • Red Hat Network (RHN) Satellite 5.x

Subscriber content preview. For full access to the Red Hat Knowledgebase, please log in.

Not a subscriber? Learn more about the benefits of Red Hat Subscriptions.