1.198. pam_krb5

An updated pam_krb5 package that fixes two bugs is now available for Red Hat Enterprise Linux 6.
The pam_krb5 module allows PAM-aware applications to verify and change user passwords with the help of a KDC.
Bug Fixes
BZ#622938
Previously, pam_krb5 ignored the "verify_ap_req_nofail" configuration setting when it checked whether the credentials from the Key Distribution Center (KDC) were spoofed because of a missing or otherwise inaccessible local keytab file. Due to this behavior, pam_krb5 wrongly returned a success message. This update reworks the credential verification. Now, the verification settings work as expected.
BZ#690583
Previously, pam_krb5 used a format for password change requests that earlier versions of kadmind could not process. This update uses application programming interfaces (API) that format password change requests which can also be parsed by earlier versions of kadmind.
All pam_krb5 users are advised to upgrade to this updated package, which fixes these bugs.