1.197. pam

Updated pam packages that fix bugs and add enhancements are now available.
Pluggable Authentication Modules (PAM) provide a system whereby administrators can set up authentication policies without having to recompile programs to handle authentication.
Bug Fixes
BZ#614766
When the pam packages were updated, the /var/log/tallylog and /var/log/faillog files were overwritten with empty files because of an incorrect condition check in the %post script. This has been corrected, and PAM no longer attempts to overwrite tallylog and faillog files when they exist prior to update.
BZ#679069
A code review revealed several small memory leaks and improperly handled error paths in pam_namespace, pam_selinux, pam_limits, pam_pwhistory, pam_time, and pam_group modules. These issues have been corrected.
Enhancements
BZ#622847
The pam_limits module, which sets resource limits for processes, now supports matching individual and ranges of user and group identifiers in its limits.conf configuration file.
BZ#644971
A new pam_faillock module was added to support temporary locking of user accounts in the event of multiple failed authentication attempts. This new module improves functionality over the existing pam_tally2 module, as it also allows temporary locking when the authentication attempts are done over a screen saver.
BZ#677664
The audit records provided by the pam_selinux and pam_tally2 modules have been improved to include tty and remote hostname information in each recorded event.
All pam users are advised to upgrade to these updated packages, which resolve these issues and add these enhancements.