4.224. yum-utils

Updated yum-utils packages that fix several bugs and add an enhancement are now available for Red Hat Enterprise Linux 5.
The yum-utils packages provide a collection of utilities and examples for the yum package manager to make yum easier and more powerful to use.

Bug Fixes

BZ#543649
Previously, a yum transaction could fail with the message that a kmod package was already installed if a kmod plug-in was installed and the "installforallkernels" option set in the /etc/yum/pluginconf.d/kmod.conf file. This happened when the requested packages were located in a different repository due to an incorrect handling of repository ID resolution. With this update, the respective method has been corrected and such yum transactions are executed successfully as expected.
BZ#732596
The manual page of the reposync tool contained an imprecise description of the "--arch" option. This update enhances the "--arch" option documentation.
BZ#711768
Previously, a package download could fail with the error message that the package already existed and appeared to be complete. This happened if the latest version of the package was available in multiple repositories because the yumdownloader tool attempted to download the package from all the repositories. With this update, yum downloads such a package only from one repository and the update process finishes successfully in the described scenario.
BZ#703372
The repomanage command failed with a traceback if it was executed on an invalid repository path. With this update, the underlying code has been modified and the command returns the "Error accessing directory" error message under these circumstances.
BZ#631843
Previously, the "--count" option was incorrectly located in the "OLDKERNELS OPTIONS" section of manual pages. However, "--count" is a general option. With this update, the "--count" option has been moved to the "GENERAL OPTIONS" section.
BZ#496580
Previously, the "package-cleanup --oldkernels" command could not handle kernel-PAE and kernel-xen packages and the command terminated with the following error message:
Error all kernel rpms are set to be removed.
With this update, the kernel-PAE and kernel-xen packages are handled correctly and the specified number of packages (by default, two packages) is kept after the command has been issued.

Enhancement

BZ#530150
This update adds the manual page for the debuginfo-install command.
All users of yum-utils are advised to upgrade to these updated packages, which fix these bugs and add this enhancement.