Red Hat Enterprise Linux 5

International Language Support Guide

Internationalization Guide

Edition 0

Legal Notice

Copyright © 2008 Red Hat.
This document is licensed by Red Hat under the Creative Commons Attribution-ShareAlike 3.0 Unported License. If you distribute this document, or a modified version of it, you must provide attribution to Red Hat, Inc. and provide a link to the original. If the document is modified, all Red Hat trademarks must be removed.
Red Hat, as the licensor of this document, waives the right to enforce, and agrees not to assert, Section 4d of CC-BY-SA to the fullest extent permitted by applicable law.
Red Hat, Red Hat Enterprise Linux, the Shadowman logo, JBoss, MetaMatrix, Fedora, the Infinity Logo, and RHCE are trademarks of Red Hat, Inc., registered in the United States and other countries.
Linux® is the registered trademark of Linus Torvalds in the United States and other countries.
Java® is a registered trademark of Oracle and/or its affiliates.
XFS® is a trademark of Silicon Graphics International Corp. or its subsidiaries in the United States and/or other countries.
MySQL® is a registered trademark of MySQL AB in the United States, the European Union and other countries.
Node.js® is an official trademark of Joyent. Red Hat Software Collections is not formally related to or endorsed by the official Joyent Node.js open source or commercial project.
The OpenStack® Word Mark and OpenStack Logo are either registered trademarks/service marks or trademarks/service marks of the OpenStack Foundation, in the United States and other countries and are used with the OpenStack Foundation's permission. We are not affiliated with, endorsed or sponsored by the OpenStack Foundation, or the OpenStack community.
All other trademarks are the property of their respective owners.

Abstract

This book is about international language support for Red Hat Enterprise Linux 5.

Chapter 1. Introduction

This guide explains how to use international languages supported in Red Hat Enterprise Linux 5. It explains how to:
  • install the packages that are required to support your language, such as fonts to display its characters and input methods.
  • set the language so that used applications will run and appear in the chosen language.
  • configure the keyboard in order to input your language correctly.
  • use the SCIM input method for Asian languages.
The next chapter introduces language support installation during and after installation. Chapter 3 describes how to change your default language while chapter 4 discusses keyboard installation and configuration. System documentation is discussed in chapter 5. Adding fonts is discussed in chapter 6 while chapter 7 describes how to use the Smart Common Input Method. Chapter 8 describes how to write in Japanese, Chinese, Korean and Indic languages. In chapter 9 advanced topics discussed include using the iconv and iconvmv tools. Language support in shipped applications including Firefox Evolution and gedit, the Gnome text editor are discussed in chapter 10.

Chapter 2. Installing and supporting languages

Red Hat Enterprise Linux 5 supports installation of multiple languages and changing of languages based on your requirements. Please only install those languages that you will use as this will save you a significant amount of disk space.
The following languages are supported in Red Hat Enterprise Linux 5:
  • East Asian Languages - Chinese (Simplified), Chinese (Traditional), Japanese and Korean.
  • European Languages - French, German, Italian, Portuguese (Brazilian), Russian and Spanish.
  • Indic Languages - Assamese, Bengali, Gujarati, Hindi, Kannada, Malayalam, Marathi, Oriya, Punjabi, Sinhalese, Tamil and Telugu.
The table below summarizes the currently supported languages, their locales, default fonts installed and packages required for some of the supported languages.

Table 2.1. Red Hat Enterprise Linux 5 International Languages

Territory Language Locale Fonts Package Names
China Simplified Chinese zh_CN.UTF-8 AR PL (ShanHeiSun and Zenkai) Uni fonts-chinese, scim-pinyin, scim-tables
Japan Japanese ja_JP.UTF-8 Sazanami (Gothic and Mincho) fonts-japanese, scim-anthy
Korea Hangul ko_KR.UTF-8 Baekmuk (Batang, Dotum, Gulim, Headline) fonts-korean, scim-hangul
Taiwan Traditional Chinese zh_TW.UTF-8 AR PL (ShanHeiSun and Zenkai) Uni fonts-chinese, scim-chewing, scim-tables
Brazil Portuguese pt_BR.UTF-8 standard latin fonts
France French ft_FR.UTF-8 standard latin fonts
Germany German de_DE.UTF-8 standard latin fonts
Italy Italy it_IT.UTF-8 standard latin fonts
Russia Russian ru_RU.UTF-8 KOI8-R, fonts-KOI8-R-100dpi, fonts-KOI8-R-75dpi and xorg-x11-fonts-cyrillic fonts-KO18-R, fonts-KO18-R-100 dpi,fonts-KO18-R-75dpi, xorg-x11-fonts-cyrillic
Spain Spanish es_ES.UTF-8 standard latin fonts
India Assamese as_IN.UTF-8 Lohit Bengali fonts-bengali, scim-m17n, m17n-db-assamese
Bengali bn_IN.UTF-8 Lohit Bengali fonts-bengali, scim-m17n, m17n-db-bengali
Gujarati gu_IN.UTF-8 Lohit Gujarati fonts-gujarati, scim-m17n, m17n-db-gujarati
Hindi hi_IN.UTF-8 Lohit Hindi fonts-hindi, scim-m17n, m17n-db-hindi
Kannada kn_IN.UTF-8 Lohit Kannada fonts-kannada, scim-m17n, m17n-db-kannada
Malayalam ml_IN.UTF-8 Lohit Malayalam fonts-malayalam, scim-m17n, m17n-db-malayalam
Marathi mr_IN.UTF-8 Lohit Hindi fonts-hindi, scim-m17n, m17n-db-marathi
Oriya or_IN.UTF-8 Lohit Oriya fonts-oriya, scim-m17n, m17n-db-oriya
Punjabi pa_IN.UTF-8 Lohit Punjabi fonts-punjabi, scim-m17n, m17n-db-punjabi
Tamil ta_IN.UTF-8 Lohit Tamil fonts-tamil, scim-m17n, m17n-db-tamil
Telugu te_IN.UTF-8 Lohit Telugu fonts-telugu, scim-m17n, m17n-db-telugu
Sri Lanka Sinhala si_LK.UTF-8 LKLUG fonts-sinhala, scim-sinhala, scim-m17n, m17n-db-sinhala

Red Hat Enterprise Linux 5 uses the UTF-8 (8bit Unicode Transformation Format) encoding for supported locales. This allows you to create, edit and view documents written in different locales using UTF-8.

Note

Please note that applications such as KDE and Open Office may use additional files for internationalization.

2.1. Adding language support during installation

During your installation, the installation language you select becomes your default language after installation. The figure below illustrates the language selection window during installation. The selected language affects the default for:
  • user interface,
  • documentation,
  • fonts,
  • date, time formats and locale information,
  • input methods for Asian languages.
These areas will be discussed later in this guide.
Select installation language

Figure 2.1. Select installation language


During installation you can also install support for multiple languages from the package selection window as illustrated below.
Package selection

Figure 2.2. Package selection


2.2. Adding language support after installation

After installation, you can still add, remove and change supported languages using the Package Manager. The Package Manager can be accessed from the system menu by clicking Applications => Add/Remove Software. In the first tab you can view the application categories among which is “Languages” from which you can select the languages you wish to support. Please select only the languages you wish to use as this can save you a significant amount of disk space. The language selection feature in the Package Manager is illustrated below. Some languages have optional packages which you can select and install.
Package Manager

Figure 2.3. Package Manager


Chapter 3. Changing the default language

You can set your default language during the installation process of Red Hat Enterprise Linux 5 which also specifies your locale settings. To change the default language you do not need to restart or reinstall Red Hat Enterprise Linux 5. You can do this as root by running the language selection application. This can be accessed from the system menu by clicking System => Administration => Language or typing system-config-language from a terminal. This displays a list of supported languages from which you can select your preference. Clicking on the OK button sets the selected language as default. The figure below illustrates the language selection application.
Language selection

Figure 3.1. Language selection


On selecting your default language, it is recommended to logout of your system in order to reload the language settings including the user interface, characters, input tables and methods.
You can also change the language used on your desktop from the GDM language menu before logging in to your desktop.

Chapter 4. Keyboard installation and configuration

During installation the keyboard you select becomes your default keyboard. You can change your default keyboard after installation or add multiple keyboards which you can change on the fly to suit your input language. The figure below illustrates the keyboard selection menu during the installation process.
Keyboard selection during installation

Figure 4.1. Keyboard selection during installation


4.1. Configuring the keyboard after installation

After installation, you can set the default keyboard by clicking System => Administration => Keyboard from the system menu panel or by typing system-config-keyboard from a terminal. This displays a list of supported keyboard from which you can select the appropriate keyboard for your system. The figure below illustrates the Keyboard Selection utility.
Keyboard selection

Figure 4.2. Keyboard selection


Chapter 5. Red Hat Enterprise Linux 5 System Documentation

Based on your selected language, the system documentation available for Red Hat Enterprise Linux 5 will be in the respective language if this is supported. The figure below illustrates optional packages listed in the Package Manager. Among the optional packages for supported languages, will be documentation in the selected language. In the figure below, the Deployment Guide is listed among the Packages available in Japanese language support.
Additional Packages - Documentation

Figure 5.1. Additional Packages - Documentation


For an updated list of available documentation for your language, please visit The Red Hat documentation Page and select a product from the list of available products. Please note that the content of this web site may vary as the site gets updated regularly.
Red Hat Documentation - Products

Figure 5.2. Red Hat Documentation - Products


The figure below illustrates the language selection page for Red Hat Enterprise Linux. From the list of languages, select your preferred language and click on the Go button to display an up to date list of available documents for your language. You can also select the preferred format for the document you wish to view or download.
Red Hat Documentation - Languages

Figure 5.3. Red Hat Documentation - Languages


Chapter 6. Fonts

By default installing support for an internationalized language in Red Hat Enterprise Linux 5 also installs the required fonts for the selected language. Table 2.1, “Red Hat Enterprise Linux 5 International Languages” summarizes a list of the fonts installed for supported languages. This chapter also explains how to install additional fonts.

Viewing content in different language

A common sign that proper fonts for a particular language are not installed is characters appear as boxes with numbers. This is the unicode box which indicates that the fonts required to display the text are missing. The figure below illustrates an example.
Fonts Missing

Figure 6.1. Fonts Missing


Please ensure that you have the correct language support packages installed for your language to display content correctly.
Red Hat Enterprise Linux uses two subsystems to manage and display fonts on the Desktop: Fontconfig and the core X Fonts system. The newer Fontconfig font subsystem simplifies font management and provides advanced display features, such as anti-aliasing. This system is used automatically for modern applications developed using the (Qt 3) or (GTK+ 2) graphical toolkits. For backward compatibility with older legacy X applications, Red Hat Enterprise Linux includes the original font subsystem, called the Core X Font subsystem. This system is provided through the X Font Server (xfs). The xfs service manages the look and scalability of older fonts within some X applications. Legacy fonts will be discussed later in this chapter.
By default, the xfs service is configured to run by default in runlevels 2, 3, 4 and 5 and can be managed using initscript utilities such as chkconfig and the Services Configuration Tool (system-config-services). The X Window System requires the xfs service in order to run.

6.1. Adding new fonts for a user

To add fonts for an individual user, copy the new fonts into the ~/.fonts/ directory in the user's home directory. Use the fc-cache command to update the font information cache, as in the following example:
fc-cache ~/.fonts/
More options on using the fc-cache can be obtained from the fc-cache man page:
man fc-cache
Another easier method to add fonts is as follows:
  • Double-click on the "Computer" icon on your desktop.
  • In the "File" menu, choose "Open Location..."
  • Type in: fonts://
  • When the fonts window appears, drag and drop the fonts to be installed into this window.
The new fonts you install should be usable by most GNOME applications. Some applications may have to be restarted to use the newly added fonts.

6.2. Adding new fonts for all users

To install fonts for all users you need to login as root and create a directory under /usr/share/fonts/ for example /usr/share/fonts/custom. Copy the fonts you wish to add into the directory you created and run:
fc-cache -f /usr/share/fonts/
All existing and new users should now be able to use the installed fonts.

6.3. Working with legacy fonts

The X server looks for a font server specified in the FontPath directive within the Files section of the /etc/X11/xorg.conf configuration file.
The X server connects to the xfs server on a specified port to acquire font information. For this reason, the xfs service must be running for X to start.

6.3.1. Adding Fonts to xfs

To add fonts to the core X font subsystem (xfs), follow these steps:
  1. If it does not already exist, create a directory called /usr/share/fonts/local/ using the following command as root:
    mkdir /usr/share/fonts/local/
    If creating the /usr/share/fonts/local/ directory is necessary, it must be added to the xfs path using the following command as root:
    chkfontpath --add /usr/share/fonts/local/ 
  2. Copy the new font file into the /usr/share/fonts/local/ directory
  3. Update the font information by issuing the following command as root:
    ttmkfdir -d /usr/share/fonts/local/ -o /usr/share/fonts/local/fonts.scale
  4. Reload the xfs font server configuration file by issuing the following command as root:
    service xfs reload

Chapter 7. Smart Common Input Method

Red Hat Enterprise Linux 5 utilizes the Smart Common Input Method (SCIM) platform to provide a user friendly interface from which you can change your input method. If SCIM is installed, it runs by default for all users.
You can change your input method on the fly using the SCIM user interface or using the SCIM keyboard shortcuts which you can also customize to suit your preferences. The following table summarizes the SCIM packages shipped in Red Hat Enterprise Linux 5.

Table 7.1. Input Method Packages in Red Hat Enterprise Linux 5

Package Description
scim Smart Common Input Method platform.
scim-anthy Engine for anthy to support Japanese character input.
scim-bridge scim-bridge client.
scim-bridge-gtk Provides GTK input method for the SCIM bridge. This package prevents possible binary conflicts with third-party applications linked against older versions of libstdc++ and is highly recommended.
scim-chewing Provides Traditional Chinese input.
scim-hangul Provides Korean Input method engine.
scim-libs SCIM libraries and GTK input method module.
scim-m17n SCIM IMEngine for m17n-lib allowing input of many languages including Indic using the input table maps from m17n-db.
scim-pinyin Simplified Chinese Smart Pinyin IMEngine for SCIM.
scim-qtimm Provides an input method module for Qt and is also recommended.
scim-sinhala Provides Sinhala Trans input method.
scim-tables Contains the Generic Table IMEngine.
scim-tables-additional Miscellaneous SCIM tables.
scim-tables-chinese Contains SCIM tables for Chinese input.

After installing or removing SCIM engine packages, it is recommended to start a new desktop session in order for the changes to be reflected in the SCIM language menu.
Your language may also require input tables which are usually named m17n-db-<language>. Where <language> represents your language such as Hindi or Telugu among others. Installing your language using the package manager usually will install the required input table and SCIM packages. If you require more input methods install the required SCIM packages according to your preferences. You can add the SCIM tables by running the Package Manager from the menu panel by clicking Applications => Add/Remove Software or typing pirut from a terminal.
To activate SCIM, start the application you wish to use (for example a text editor or browser) and press CTRL and SPACE simultaneously to display the SCIM panel as illustrated below. To de-activate SCIM press CTRL and SPACE simultaneously.
SCIM Panel

Figure 7.1. SCIM Panel


You can select an input method by clicking on the displayed input method which allows you to view and select installed input methods. The SCIM language menu allows you to select your input method from the list of input methods configured in the IMEngine Global Setup. You can activate the SCIM language menu by clicking on the SCIM panel. The figure below illustrates the SCIM language menu. Please note that your SCIM language menu may vary depending on the number of languages you have installed in your system. To select an input method, select the preferred language and available input methods. If the desired language is not available, please ensure it is installed or follow the steps in Chapter 2, Installing and supporting languages.
SCIM language menu

Figure 7.2. SCIM language menu


7.1. Configuring SCIM

Configuration of Hotkeys and general configuration
You can configure the front end setup for SCIM in the Global Setup under the FrontEnd menu item as illustrated below. Here you can configure the keyboard layout and some hotkeys. The keyboard layout configuration specifies how SCIM maps some IMEngines to your keyboard layout. Select your respective keyboard's layout from the 'Keyboard Layout' section in the window. From Figure 7.3, “SCIM FrontEnd Global Setup” below, the selected keyboard layout is 'English (US)'.
SCIM FrontEnd Global Setup

Figure 7.3. SCIM FrontEnd Global Setup


The Panel list item allows you to configure the SCIM toolbar and its behavior. You can set when and how to show the SCIM toolbar and any candidate window. The SCIM toolbar is illustrated in Figure 7.1, “SCIM Panel” while the input language menu is illustrated in Figure 7.2, “SCIM language menu”.
You can configure SCIM by right clicking on the SCIM notification icon displayed on your taskbar and selecting SCIM Setup. You can also configure SCIM by clicking on System => More Preferences => SCIM Input Method Setup from your system menu.
How to change the language menu
In the SCIM window under the IMEngine list select the Global Setup option as illustrated below.
SCIM IMEngine Global Setup

Figure 7.4. SCIM IMEngine Global Setup


This will display the installed input method engines. Deselect those languages you do not intend to input in. Also deselect any input methods you do not wish to use for the languages you wish to input in. Please refer to Table 7.1, “Input Method Packages in Red Hat Enterprise Linux 5” and Table 2.1, “Red Hat Enterprise Linux 5 International Languages” both of which indicates the supported input methods and for Red Hat Enterprise Linux 5.
Configuration of input method
Some customizable input methods may be listed under IMEngine as illustrated in Figure 7.4, “SCIM IMEngine Global Setup”. Selecting an input method from the list will display the setup options available. Please note that the setup options vary from one input method to another.

Chapter 8. Writing Asian and Indic Languages

Please ensure that your preferred language is installed from the list of supported languages before attempting to change your input method. Please also ensure that you have configured a suitable keyboard for your selected language. The following are examples on how to write in specific languages.

8.1. How to write in Japanese

  1. Start the application you wish to write in and press the CTRL and SPACE keys to start or stop SCIM. If using a Japanese keyboard, you can also start and stop SCIM by pressing the Zenkaku-Hankaku key. When started a SCIM tool bar will be displayed on the right corner of your screen as illustrated below.
    SCIM Toolbar - Anthy

    Figure 8.1. SCIM Toolbar - Anthy


  2. If Anthy is not displayed, click on the displayed input method and select Japanese from the list of languages displayed. If Japanese is not listed, this is an indication that you have not added Japanese language support in your system. For more information on adding language support, please read Section 2.2, “Adding language support after installation”.
    On selecting Japanese as your input language, you can start typing. You can press the SPACE key to start Kanji conversion. If you press the SPACE key a second time, a look up window will be displayed as you type your phrases with suggestions which you can select from. To navigate through the list of candidate phrases, you may use the UP and DOWN arrow keys or the SPACE bar. Use the RETURN key to commit your selection to the document.
    The input mode button allows you to select your input mode. If using a Japanese keyboard, you can convert between Hiragana and Katanaka by pressing the Hiragana-Katakana key. You can also convert input to Hiragana by pressing the F6 key. To convert to Katanaka press the F7 key. Other input modes available are Half Width Katanaka, Latin and Wide Latin. You can switch to Half-Width Katakana using the F8 key and to Wide Latin using the F9 key. The figure below illustrates the input mode options.
    Anthy Input Mode

    Figure 8.2. Anthy Input Mode


    You can also set the conversion mode for your typing to Multi Segment and Single Segment. You can also set your phrases to be converted as you type in either Multi or Single Segments. The figure below illustrates the conversion mode options.
    Anthy Conversion Mode

    Figure 8.3. Anthy Conversion Mode


    If you wish to add a word to the dictionary, you can do so by clicking on the dictionary icon on the SCIM toolbar. The dictionary tool allows you to add, edit or remove dictionary words. The figure below illustrates the dictionary options available. On clicking the preferred option, you may be required to select your input method by pressing CTRL and SPACE keys and selecting your input method as the dictionary icon executes an application called kasumi which you can also execute from a terminal.
    Anthy Dictionary

    Figure 8.4. Anthy Dictionary


    For more shortcuts and descriptions of the input method options, click on the help icon on the SCIM toolbar.

8.2. How to write in Chinese

Please note that Red Hat Enterprise Linux 5 supports the Chewing input method for traditional Chinese and Smart-Pinyin for simplified Chinese.

8.2.1. Writing in Simplified Chinese with Smart Pinyin

To write in Simplified Chinese with Smart Pinyin, start the application you wish to write in and press CTRL and SPACE keys simultaneously to display the SCIM toolbar. Click on the language toolbar and select Chinese (simplified) and Smart Pinyin from the list of languages displayed. If Chinese is not displayed, this is an indication that you have not added Chinese language support in your system. For more information on adding language support, please read Section 2.2, “Adding language support after installation”.
On selecting Smart Pinyin, you can then start typing. A look up window will be displayed as you type your words with suggestions which you can select from. Press the number keys to select your preferred phrase and the SPACE key to add it to your document. For more shortcuts and descriptions of the input method options, click on the SCIM help icon on the toolbar.
SCIM Toolbar - Smart Pinyin

Figure 8.5. SCIM Toolbar - Smart Pinyin


8.2.2. Writing in Traditional Chinese with Chewing

Start the application you wish to write in and press CTRL and SPACE simultaneously to start SCIM. The SCIM tool bar will be displayed on the bottom right corner of your screen from which you can select your desired input method. To write with Chewing, select Chinese (traditional) from the list of languages displayed and select Chewing. If Chinese is not displayed, this is an indication that you have not added Chinese language support in your system. For more information on adding language support, please read Section 2.2, “Adding language support after installation”. You can then start typing using your desired input method. If you press space, a look up window will be displayed with suggested phrases which you can select from.
Press the <number> key to select your preferred phrase (where <number> is the number of the word from the list displayed). Press the RETURN key on your keyboard to select the selected phrase and add it to your document.
For more shortcuts and descriptions of the input method options click on the SCIM help icon on the toolbar.
SCIM Toolbar - Chewing

Figure 8.6. SCIM Toolbar - Chewing


8.3. How to write in Korean

  1. Start the application you wish to write in and press CTRL and SPACE keys simultaneously to start or stop SCIM. When started, the SCIM tool bar will be displayed on the right corner of your screen.
  2. Using your mouse, click on the displayed input method if 'Hangul' is not displayed and select Korean from the list of languages displayed. The scim toolbar will display 'Hangul' when Korean is selected as illustrated below. You can then start typing.
    SCIM Toolbar - Hangul

    Figure 8.7. SCIM Toolbar - Hangul


  3. You can also switch between Latin (abc..) and Hangul input by clicking on the input mode button as illustrated below.
    Hangul Input Mode

    Figure 8.8. Hangul Input Mode


  4. The input layout button allows you to select your preferred input layout.
    Hangul Input Layout

    Figure 8.9. Hangul Input Layout


    You can use the F9 key to convert input to Hanja characters. Pressing on the SCIM Help icon in the toolbar displays a summary of the shortcuts and their usage.

8.4. How to write in Indic Languages

Most Indic languages have 3 types of keymaps, namely:
  1. Inscript - This keymap is defined according to the Government standards.
  2. Phonetic - A phonetic keymap has keys mapped according to the sound of the alphabet. For example, for Hindi, "क" is mapped to "k"
  3. Itrans - An Itrans keymap is similar to phonetic - but has all the combined half characters (halants) mapped separately. There are no halants in Itrans.
Other keymaps are language dependant. For example, many languages have:
  1. Typewriter - A keymap which functions like an actual typewriter
  2. Language specific - Popular keymaps from the community - KGP for Kannada, Tamil99 for Tamil, etc.
To write in an Indic language perform the following:
  1. Start the application you wish to write in and press CTRL and SPACE keys simultaneously to start SCIM. A SCIM toolbar will be displayed on the right corner of your screen from which you can select your desired language as illustrated in Figure 8.10, “SCIM Toolbar - Indic”. Please note that your default language may vary depending on your language settings. To stop SCIM, press the CTRL and SPACE keys simultaneously again.
    SCIM Toolbar - Indic

    Figure 8.10. SCIM Toolbar - Indic


  2. To change your language, click on the displayed language or keymap and select your language and type of keymap from the list of languages displayed as illustrated in figure Figure 7.2, “SCIM language menu”. You can now start typing in your selected language. Please note that your language menu may vary depending on your language settings.
  3. To access help for a particular keymap, select the keymap and click on the Help icon on the SCIM toolbar. This will pop-up a dialog box, displaying the help associated with the current keymap.

Chapter 9. Advanced Topics

9.1. Using the iconv tool

The iconv tool converts the encoding of characters in a file from one coded character set to another. The result is written to standard output unless otherwise specified by the --output option. When doing conversions it is always a good idea to backup ones original files first.
The following are some useful examples of using the iconv tool.
  • List character-set encoding names:
    iconv --list
  • Convert ISO8859-1 (legacy Western European) content to utf-8
    iconv -f ISO_8859-1 -t UTF-8 oldfile > newfile
    In the above example, the oldfile is encoded in ISO8859-1, while the "newfile" will be encoded in UTF-8.
  • Similarly to convert EUCJP content to UTF-8
    iconv -f EUCJP -t UTF-8 oldfile > newfile
See the iconv (1) manpage for more details.

9.2. Using the convmv tool

The convmv is a tool for converting the character-set encoding of file names. It is particularly useful for converting file names encoded in a legacy charset encoding such as ISO-8859 to UTF-8, or EUC to UTF-8. Please ensure you install the convmv package to use this tool. The following are examples of options available using the convmv tool.
  • List character-set encoding names:
    convmv --l
convmv runs in test mode by default, one needs to use the --notest option for the changes to be actually effected.
  • Convert ISO8859-1 (legacy Western European) filenames in directory DIR to UTF-8
    convmv -f iso-8859-1 -t utf8 DIR
  • Similarly, convert EUCJP filenames in DIR to UTF-8
    convmv -f euc-jp -t utf8 DIR
See the convmv (1) manpage for more details.

Chapter 10. Language support in shipped applications

Some applications shipped with Red Hat Enterprise Linux 5 support multiple languages. This section discusses some of these applications.

10.1. Language support in Firefox

Firefox is the default web browser in RHEL5. Firefox allows you to browse web pages in many languages. An upto date list of languages supported in the latest release of Firefox can be found on http://www.mozilla.com/en-US/firefox/all.html.
Web pages you access may be available in more than one language. To display pages in your preferred language, please set your preferred language order by selecting from the Firefox menu Edit > Preferences > Advanced icon > General tab and Language section. Click on the Choose button to add or edit your preferred languages list. The Languages window will be displayed listing the order of preference for languages you wish to display content in. Click on the Select a language to add... list to display a list of languages supported by your version of Firefox. Languages not listed are not supported. Click on the Add button to add the selected language. You may then move your preferred languages up or down the list of preferred languages. You can also remove a language from the list of prefer ed languages by selecting it and clicking on the Remove button. When done click on the OK button to save your changes or Cancel to cancel the operation.
More documentation on the firefox web browser can be found by clicking on the Help menu item and selecting Help Contents F1 or by pressing the F1 key on your keyboard while the Firefox browser window is active.

10.2. Language support in Evolution

Evolution is a communications tool that helps you manage your emails, address book, tasks and multiple calendars.
If you wish to write an email in a supported preferred language, open a mail composition window for a new mail or click on reply or forward for an existing email. To change the encoding of your mail, select Edit > Character encoding and choose the language encoding that you wish to send the message in. You can set the default encoding for messages you receive and send by selecting in the main window Edit > Preferences, then select the Mail Preferences or Composer Preferences sections. These contain a Default character encoding list from which you can select your preferred character encoding. If you are unsure which encoding to use, select UTF-8, which offers the greatest range of character displays for the greatest range of languages.
More information on Language support for Evolution can be found on the application's documentation which can be obtained by pressing F1 while the application window is active. You can also click on the Help menu item and selecting Contents F1 from the list of options.

10.3. Language support in gedit

gedit is the official text editor used in the GNOME desktop. gedit also provides support for syntax highlighting for various programming languages including C, C++, Java, HTML, XML, Python, Perl among others.
When opening a file (from the menu File > Open), you can specify the character encoding for a file under the Character Coding section in the Open File window. By default gedit can also auto detect the character encoding.
When saving a file (from the menu File > Save As) you can also specify the character encoding to use for the file in the Character Coding section of the "Save As" window. On selecting the preferred character encoding, click on the Save button. More information on using gedit including latest updates can be obtained on http://www.gedit.org.

Keyboard layouts

This section outlines the Indic language keyboard layouts supported by Red Hat Enterprise Linux 5.

A.1. Indic Languages

The following illustrations are for inscript keyboards for Indic Languages.
Assamese Inscript Layout.

Figure A.1. Assamese Inscript Layout.


Bengali Inscript Layout.

Figure A.2. Bengali Inscript Layout.


Gujarati Inscript Layout.

Figure A.3. Gujarati Inscript Layout.


Hindi Inscript Layout.

Figure A.4. Hindi Inscript Layout.


Kannada Inscript Layout.

Figure A.5. Kannada Inscript Layout.


Malayalam Inscript Layout.

Figure A.6. Malayalam Inscript Layout.


Marathi Inscript Layout.

Figure A.7. Marathi Inscript Layout.


Oriya Inscript Layout.

Figure A.8. Oriya Inscript Layout.


Punjabi Inscript Layout.

Figure A.9. Punjabi Inscript Layout.


Telugu Inscript Layout.

Figure A.10. Telugu Inscript Layout.