35.2. Viewing Log Files

Most log files are in plain text format. You can view them with any text editor such as Vi or Emacs. Some log files are readable by all users on the system; however, root privileges are required to read most log files.
To view system log files in an interactive, real-time application, use the Log Viewer. To start the application, go to Applications (the main menu on the panel) => System Tools => System Logs, or type the command system-logviewer at a shell prompt.
The application only displays log files that exist; thus, the list might differ from the one shown in Figure 35.1, “Log Viewer.
To filter the contents of the log file for keywords, type the keyword(s) in the Filter for text field, and click Filter. Click Reset to reset the contents.
Log Viewer

Figure 35.1. Log Viewer


By default, the currently viewable log file is refreshed every 30 seconds. To change the refresh rate, select Edit => Preferences from the pulldown menu. The window shown in Figure 35.2, “Log File Locations” appears. In the Log Files tab, click the up and down arrows beside the refresh rate to change it. Click Close to return to the main window. The refresh rate is changed immediately. To refresh the currently viewable file manually, select File => Refresh Now or press Ctrl+R.
On the Log Files tab in the Preferences, the log file locations can be modified. Select the log file from the list, and click the Edit button. Type the new location of the log file or click the Browse button to locate the file location using a file selection dialog. Click OK to return to the preferences, and click Close to return to the main window.
Log File Locations

Figure 35.2. Log File Locations