CVE-2011-3131

Impact:
Moderate
Public Date:
2011-08-12
Bugzilla:
730341: CVE-2011-3131 kernel: xen: IOMMU fault livelock

The MITRE CVE dictionary describes this issue as:

Xen 4.1.1 and earlier allows local guest OS kernels with control of a PCI[E] device to cause a denial of service (CPU consumption and host hang) via many crafted DMA requests that are denied by the IOMMU, which triggers a livelock.

Find out more about CVE-2011-3131 from the MITRE CVE dictionary dictionary and NIST NVD.

Statement

The versions of the Linux kernel as shipped with Red Hat Enterprise Linux 4, 6,
and Red Hat Enterprise MRG are not affected. It has been addressed in Red Hat Enterprise Linux 5 via https://rhn.redhat.com/errata/RHSA-2011-1386.html.

CVSS v2 metrics

Base Score 5.2
Base Metrics AV:A/AC:M/Au:S/C:N/I:N/A:C
Access Vector Adjacent Network
Access Complexity Medium
Authentication Single
Confidentiality Impact None
Integrity Impact None
Availability Impact Complete

Find out more about Red Hat support for the Common Vulnerability Scoring System (CVSS).

Red Hat Security Errata

Platform Errata Release Date
Red Hat Enterprise Linux 5 (kernel) RHSA-2011:1386 2011-10-20

Affected Packages State

Platform Package State
Red Hat Enterprise Linux 5 kernel-xen Will not fix

Last Modified

CVE description copyright © 2017, The MITRE Corporation