CVE-2010-4150

Impact:
Low
Public Date:
2010-11-02
Bugzilla:
656917: CVE-2010-4150 php: Double free in the imap extension

The MITRE CVE dictionary describes this issue as:

Double free vulnerability in the imap_do_open function in the IMAP extension (ext/imap/php_imap.c) in PHP 5.2 before 5.2.15 and 5.3 before 5.3.4 allows attackers to cause a denial of service (memory corruption) or possibly execute arbitrary code via unspecified vectors.

Find out more about CVE-2010-4150 from the MITRE CVE dictionary dictionary and NIST NVD.

Statement

We do not consider safe_mode / open_basedir restriction bypass issues to be
security sensitive. For more details see
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=169857#c1 and
http://www.php.net/security-note.php

Red Hat Enterprise Linux 4:
This vulnerability has been rated as having a security impact of Low. After evaluation and in accordance with the criteria noted in the product support life cycle, there are no plans to address this issue in an upcoming release. Please contact Red Hat Support for further information.

Red Hat Enterprise Linux 5:
This vulnerability has been rated as having a security impact of Low. After evaluation and in accordance with the criteria noted in the product support life cycle, there are no plans to address this issue in an upcoming release. Please contact Red Hat Support for further information.

Red Hat Enterprise Linux 6:
This vulnerability has been rated as having a security impact of Low. After evaluation and in accordance with the criteria noted in the product support life cycle, there are no plans to address this issue in an upcoming release. Please contact Red Hat Support for further information.

CVSS v2 metrics

NOTE: The following CVSS v2 metrics and score provided are preliminary and subject to review.

Base Score 3.6
Base Metrics AV:L/AC:L/Au:N/C:N/I:P/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact Partial

Find out more about Red Hat support for the Common Vulnerability Scoring System (CVSS).

Affected Packages State

Platform Package State
Red Hat Enterprise Linux 6 php Will not fix
Red Hat Enterprise Linux 5 php Will not fix
Red Hat Enterprise Linux 4 php Will not fix
Unless explicitly stated as not affected, all previous versions of packages in any minor update stream of a product listed here should be assumed vulnerable, although may not have been subject to full analysis.
Last Modified

CVE description copyright © 2017, The MITRE Corporation