api.openshift.com Offline Access Token Expired
Environment
- rosa command-line tool (rosa CLI)
- ocm-cli tool (ocm CLI)
- Using the ocm-sdk-go client library
Issue
- My api.openshift.com offline access token has expired
-
I see the following error message when using the
rosa
orocm
CLI tools:.Can't get tokens .... Can't get access tokens ....
Resolution
A new offline access token must be generated at one of the specified URLs below. Each time the URL is visited, a new offline access token is generated.
- Red Hat OpenShift Service on AWS (ROSA): https://cloud.redhat.com/openshift/token/rosa
- OpenShift Cluster Manager (OCM): https://cloud.redhat.com/openshift/token
Root Cause
In some cases, sso.redhat.com may invalidate this token, requiring it to be regenerated. The Red Hat Engineering teams are working to provide better error messages and documentation. However, if you encounter an error message like the messages mentioned above, obtain a new token as described in the Resolution section.
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