Warning message

This translation is outdated. For the most up-to-date information, please refer to the English version.

yum が失敗し rpm_check_debug vs depsolve エラーが発生する

Solution Verified - Updated -

Issue

  • yum が失敗し、以下のような rpm_check_debug vs depsolve エラーが表示されるのはなぜですか?
# yum update
...
---> Package dracut-kernel.noarch 0:004-336.el6_5.2 will be an update
--> Finished Dependency Resolution
Dependencies Resolved
...
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
libgcc_s.so.1 is needed by compat-libstdc++-33-3.2.3-69.el6.i686
libgcc_s.so.1(GCC_3.0) is needed by compat-libstdc++-33-3.2.3-69.el6.i686
libgcc_s.so.1(GCC_3.3) is needed by compat-libstdc++-33-3.2.3-69.el6.i686
libgcc_s.so.1(GLIBC_2.0) is needed by compat-libstdc++-33-3.2.3-69.el6.i686
** Found 7 pre-existing rpmdb problem(s), 'yum check' output follows:
compat-libstdc++-33-3.2.3-47.3.i386 has missing requires of libgcc_s.so.1
compat-libstdc++-33-3.2.3-47.3.i386 has missing requires of libgcc_s.so.1(GCC_3.0)
compat-libstdc++-33-3.2.3-47.3.i386 has missing requires of libgcc_s.so.1(GCC_3.3)
compat-libstdc++-33-3.2.3-47.3.i386 has missing requires of libgcc_s.so.1(GLIBC_2.0)
smbios-utils-bin-2.2.26-3.1.sles10.x86_64 has missing requires of libsmbios2 = ('0', '2.2.26', '3.1.sles10')
smbios-utils-bin-2.2.26-3.1.sles10.x86_64 has missing requires of libsmbios.so.2()(64bit)
smbios-utils-bin-2.2.26-3.1.sles10.x86_64 has missing requires of libsmbios_c.so.2()(64bit)
Your transaction was saved, rerun it with: yum load-transaction /tmp/yum_save_tx-2013-12-02-15-07KoXBJz.yumtx

Environment

  • Red Hat Enterprise Linux(RHEL) 6.x
  • Red Hat Network (RHN)

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In

New to Red Hat?

Learn more about Red Hat subscriptions

Using a Red Hat product through a public cloud?

How to access this content