Warning message

This translation is outdated. For the most up-to-date information, please refer to the English version.

yum update を実行すると This system is registered to Red Hat Subscription Management, but is not receiving updates. You can use subscription-manager to assign subscriptions エラーメッセージが発生する

Solution Unverified - Updated -

Environment

  • Red Hat Subscription Manager
  • Red Hat Enterprise Linux 5
  • Red Hat Enterprise Linux 6
  • Red Hat Enterprise Linux 7

Issue

  • yum update を実行すると、以下のエラーメッセージが表示されます。
This system is registered to Red Hat Subscription Management, but is not receiving updates.You can use subscription-manager to assign subscriptions
  • rhsm.log からの抜粋:
[DEBUG] subscription-manager @identity.py:130 - Loading consumer info from identity certificates.
[DEBUG] subscription-manager @connection.py:418 - Loaded CA certificates from /etc/rhsm/ca/: candlepin-stage.pem, redhat-uep.pem
[DEBUG] subscription-manager @connection.py:450 - Making request: GET /subscription/status
[DEBUG] subscription-manager @connection.py:473 - Response: status=200
[WARNING] subscription-manager @connection.py:477 - Clock skew detected, please check your system time
[INFO] subscription-manager @managercli.py:299 - Server Versions: {'candlepin': '0.9.26-1', 'server-type': 'Red Hat Subscription Management'}
subscription-manager @connection.py:418 - Loaded CA certificates from /etc/rhsm/ca/: candlepin-stage.pem, redhat-uep.pem
subscription-manager @connection.py:450 - Making request: GET /subscription/
subscription-manager @connection.py:473 - Response: status=200
  • 発生している問題:
[root@host]# yum update
Loaded plugins: product-id, subscription-manager
This system is registered to Red Hat Subscription Management, but is not 
receiving updates.You can use subscription-manager to assign subscriptions.
There are no enabled repos.
  Run "yum repolist all" to see the repos you have.
  You can enable repos with yum-config-manager --enable <repo>
  • ポータルシステムの状態は Subscribed となっています。

Resolution

  • 日時設定が間違っています。reset the date and time in the system properly. を参照して日時を変更します。この問題は、登録されているシステムにサブスクリプションが追加されていない場合に発生する場合があります。以下のコマンドを実行すると、利用可能なサブスクリプションを自動的に追加できます。
# subscription-manager attach --auto

Root Cause

  • 日時設定が間違っているか、システムにサブスクリプションが登録されていません。

This solution is part of Red Hat’s fast-track publication program, providing a huge library of solutions that Red Hat engineers have created while supporting our customers. To give you the knowledge you need the instant it becomes available, these articles may be presented in a raw and unedited form.

2 Comments

わたしも今同じ症状です。

Resolution •日時設定が間違っています。システムの時間を正しく設定し直してください。

これをするにはどうしたらいいのでしょう。dateで見た時には時間はあっているようなのですが。

ひとまず一般的なトラブルシューティング ( https://access.redhat.com/ja/solutions/321223 ) をお試し頂き、改善しないようであれば、カスタマーポータル上部の "サポートケースを管理" を開き "サポートケースを新規作成" からお問い合わせくださいますようお願い致します。