Openshift Online アプリケーションが定期的に利用できなくなる
Environment
Openshift Online 2.0.41
Issue
アプリケーションの問題が発生しています。数日に 1 回、"Service Temporarily Unavailable" な状態になります。メモリ使用量を監視していますが、リークはないようです。これは、単純な CRUD アプリケーションです。
Resolution
この問題が今後発生しないように、ノードのメモリ設定を変更しました。
Root Cause
この問題の発生時、Openshift Node でメモリ不足になるイベントが発生したため、アプリケーションが再起動しました。
Diagnostic Steps
-
"Service Unavailable Exception" が最後に発生した後のアプリケーションログをアップロードしてください。SCP を使用してローカルマシンにコピーすると、ログを取得できます。
scp <UID>@app-domain.rhcloud.com:~/<cartridge>/logs/<cartridge>.log .
問題発生時にアプリケーションが起動していることが、アプリケーションログに示されています。
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