Warning message

This translation is outdated. For the most up-to-date information, please refer to the English version.

JBoss Enterprise BRMS でサポートされる構成

注意: オリジナルページ (英語) が更新されている可能性があります。最新の情報については、そちらをご確認ください。

JBoss® Enterprise BRMS のすべてのリリースは、主要なオペレーティングシステム、Java™ 仮想マシン (JVM)、データベースのさまざまな組み合わせについてテストされ、認定されています。すべての組み合わせをテストすることはできないため、このページでは、サポートされ、互換性がある構成について説明します。Red Hat® は、認定済みの構成および互換性のある構成の両方をサポートします。

互換性のある構成

互換性のある構成には、JBoss Enterprise Application Platform でサポートされるすべてのオペレーティングシステムが含まれます。このオペレーティングシステムでは、下記の互換性のある構成の表に含まれる JVM バージョンとデータベースを実行しています。Red Hat は、互換性のある構成に対して、プロダクションサポートと開発サポートを、お客様のサブスクリプション契約に従って提供します。ただし、JBoss Enterprise BRMS 上で実行しているアプリケーションや、JBoss Enterprise BRMS を利用しているアプリケーションだけがサポート対象となります。Red Hat は、JVM のテストおよび認定のプロセスに基づいてプラットフォームの互換性を判定しています。

認定済みの構成

認定済みの構成とは、検証とテストが行われ、推奨されているオペレーティングシステム、チップアーキテクチャー、JVM、データベースの組み合わせの定義済みセットです。これらの構成について、Red Hat は直接または認定パートナーを通して、製品リリースプロセスの過程で幅広いプラットフォーム認定テストを実施しています。このテストプロセスの過程で確認された問題は、JBoss Enterprise BRMS の各リリースのリリースノートに明記されています。認定済みの構成のリストは随時追加されます。

JBoss Enterprise BRMS 5.3

互換性のある構成 - 5.3

Red Hat は、JVM のテストおよび認定のプロセスに基づいてプラットフォームの互換性を判定しています。以下に示す構成は、仮想環境または物理環境において、JBoss Enterprise BRMS 5.3 に対する「互換性のある構成」と見なされ、サポートされます。

Java 仮想マシン バージョン
Sun JDK 1.6.x、1.7
IBM JDK 1.6.x
Open JDK 1.6.x、1.7
Apple JDK 1.6.x

認定済みの構成 - 5.3

以下に示すオペレーティングシステム、チップアーキテクチャー、JVM の組み合わせは、JBoss Enterprise BRMS 5.3 でサポートされる認定済みの構成です。

オペレーティングシステム チップアーキテクチャー Java 仮想マシン
Red Hat Enterprise Linux 6 (最新アップデート) x86、x86_64 Sun JDK 1.6、1.7 IBM JDK 1.6、Open JDK 6、7
Red Hat Enterprise Linux 5 (最新アップデート) x86、x86_64 Sun JDK 1.6、IBM JDK 1.6、Open JDK 6
Microsoft Windows 2003 x86、x86_64 Sun JDK 1.6、1.7
Microsoft Windows Server 2008 x86、x86_64 Sun JDK 1.6、1.7
Solaris 9 と Solaris 10 Sparc、x86 Sun JDK 1.6、1.7
AIX 5.3 x64 Sun JDK 1.6、IBM JDK 1.6

以下に示すコンテナーは、JBoss Enterprise BRMS 5.3 でサポートされる認定済みの構成です。

Java EE コンテナー バージョン
JBoss EAP 6.0 (BRMS 5.3.1) および 5.1.2
JBoss Enterprise SOA Platform 5.3
JBoss EWS 1.0.2、2 (BRMS 5.3.1)
Apache Tomcat 6、7 (BRMS 5.3.1)

以下に示すデータベースは、JBoss Enterprise BRMS 5.3 リリースプロセスの過程で検証と認定が行われました。

データベース
Oracle 11g R2
PostgreSQL 8.2、8.3、8.4
MySQL 5.0 および 5.1
MSSQL Server 2008 R2
DB2 9.7

以下に示す Web ブラウザーは、JBoss Enterprise BRMS 5.3 リリースプロセスの過程でテストされました。

  • Firefox 10
  • Safari 5
  • Safari 4
  • IE 9 (BRMS 5.3.1 以降は、Chrome プラグインからテストされています)

JBoss Enterprise BRMS 5.2

互換性のある構成 - 5.2

Red Hat は、JVM のテストおよび認定のプロセスに基づいてプラットフォームの互換性を判定しています。以下に示す構成は、仮想環境または物理環境において、JBoss Enterprise BRMS 5.2 に対する「互換性のある構成」と見なされ、サポートされます。

Java 仮想マシン バージョン
Sun JDK 1.6
IBM JDK 1.6
Open JDK 6
Apple JDK 6

認定済みの構成 - 5.2

以下に示すオペレーティングシステム、チップアーキテクチャー、JVM の組み合わせは、JBoss Enterprise BRMS 5.2 でサポートされる認定済みの構成です。

オペレーティングシステム チップアーキテクチャー Java 仮想マシン
Red Hat Enterprise Linux 6 (最新アップデート) x86、x86_64 Sun JDK 1.6、IBM JDK 1.6、Open JDK 6
Red Hat Enterprise Linux 5 (最新アップデート) x86、x86_64 Sun JDK 1.6、IBM JDK 1.6、Open JDK 6
Microsoft Windows 2003 x86、x86_64 Sun JDK 1.6
Microsoft Windows Server 2008 x86、x86_64 Sun JDK 1.6
Solaris 9 と Solaris 10 Sparc、x86 Sun JDK 1.6
AIX 5.3 x64 Sun JDK 1.6、IBM JDK 1.6

以下に示すコンテナーは、JBoss Enterprise BRMS 5.2 でサポートされる認定済みの構成です。

Java EE コンテナー バージョン
JBoss EAP 5.1.1
JBoss EWP 5.1.1
JBoss Enterprise SOA Platform 5.2
JBoss EWS 1.0.2
Apache Tomcat 5
Apache Tomcat 6

以下に示すデータベースは、JBoss Enterprise BRMS 5.2 リリースプロセスの過程で検証と認定が行われました。

データベース
Oracle 11g R2
PostgreSQL 8.2、8.3、8.4
MySQL 5.0 および 5.1
MSSQL Server 2008 R2
DB2 9.7

以下に示す Web ブラウザーは、JBoss Enterprise BRMS 5.2 リリースプロセスの過程でテストされました。

  • Firefox 3
  • IE 8
  • IE 7
  • Safari 5
  • Safari 4

JBoss Enterprise BRMS 5.1

互換性のある構成 - 5.1

Red Hat は、JVM のテストおよび認定のプロセスに基づいてプラットフォームの互換性を判定しています。以下に示す構成は、仮想環境または物理環境において、JBoss Enterprise BRMS 5.1 に対する「互換性のある構成」と見なされ、サポートされます。

Java 仮想マシン バージョン
Sun JDK 1.5.x、1.6.x
IBM JDK 1.6 SR6
Open JDK[1] 1.6[1]

認定済みの構成 - 5.1

{#Cert_5_1}

以下に示すオペレーティングシステム、チップアーキテクチャー、JVM の組み合わせは、JBoss Enterprise BRMS 5.1 でサポートされる認定済みの構成です。

オペレーティングシステム チップアーキテクチャー Java 仮想マシン
Red Hat Enterprise Linux 6 (最新アップデート) [1] x86、x86_64 Sun JDK 1.6.0_07
Red Hat Enterprise Linux 5 (最新アップデート) x86、x86_64 Sun JDK 1.6
Red Hat Enterprise Linux 4 (最新アップデート) [1] x86、x86_64 Sun JDK 1.6.0_07
Microsoft Windows 2003 x86 Sun JDK 1.6.0_07
Microsoft Windows 2003 x86_64 Sun JDK 1.6.0_07
Solaris 10[1] SPARC、x86 Sun JDK 1.6
AIX 5.3[1] x86、x86_64 Sun JDK 1.6

以下に示すデータベースとデータベースドライバーは、JBoss Enterprise BRMS 5.1 リリースプロセスの過程で検証と認定が行われました。

データベース データベースドライバー
Oracle 11g Oracle JDBC ドライバー v11.2.0.1.0
PostgreSQL 8.3.4[1] および 8.4[1] postgresql-8.1-410.jdbc3[1]
MySQL 5.1[1] mysql-connector-java-5.0.7[1]
MSSQL Server 2005[1] msjdbc-2.0.1008.2[1] および jtds-1.2.2[1]

以下に示す Web ブラウザーは、JBoss Enterprise BRMS 5.1 リリースプロセスの過程でテストされました。

  • Firefox 3
  • IE 8
  • IE 7
  • Safari 5[1]
  • Safari 4[1]

JBoss Enterprise BRMS 5.0

互換性のある構成 - 5.0

Java 仮想マシン バージョン
Sun JDK 1.5.x、1.6.x
IBM JDK 1.6 SR6
Open JDK 1.6.x

認定済みの構成 - 5.0

以下に示すオペレーティングシステム、チップアーキテクチャー、JVM の組み合わせは、JBoss Enterprise BRMS 5.0 で完全にサポートされる認定済みの構成です。

オペレーティングシステム チップアーキテクチャー Java 仮想マシン
Red Hat Enterprise Linux 5 (最新アップデート) x86、x86_64 Sun JDK 1.6.0_07
Sun JDK 1.5.0_15
Red Hat Enterprise Linux 4 (最新アップデート) x86、x86_64 Sun JDK 1.6.0_07
Sun JDK 1.5.0_15
Microsoft Windows 2003 x86 Sun JDK 1.6.0_07
Sun JDK 1.5.0_15
Microsoft Windows 2003 x86_64 Sun JDK 1.6.0_07
Sun JDK 1.5.0_15

以下に示すデータベースとデータベースドライバーは、JBoss Enterprise BRMS 5.0 リリースプロセスの過程で検証と認定が行われました。

データベース データベースドライバー
Oracle 10g R2 Oracle JDBC ドライバー v10.2.0.2
PostgreSQL 8.2.3 postgresql-8.1-410.jdbc3
MySQL 5.0.27 mysql-connector-java-5.0.7
MSSQL Server 2005 msjdbc-2.0.1008.2 および jtds-1.2.2

以下に示す Web ブラウザーは、JBoss Enterprise BRMS 5.0 リリースプロセスの過程でテストされました。

  • Firefox 3
  • IE 6
  • IE 7
  • Safari 3

注意

[1] これらの構成のサポートは、GA リリース後に提供されます。最新情報については、このページで再度確認してください。