Configurazioni supportate di JBoss Operations Network

NOTA: questa traduzione potrebbe non essere corrente. Per informazioni aggiornate, fare riferimento alla versione in lingua inglese.

Tutte le versioni di JBoss® Operations Network (JBoss ON) vengono sottoposte a test e certificate su molte diverse combinazioni tra i sistemi operativi, le JVM (Java™ Virtual Machine) e i database più diffusi sul mercato. Poiché non siamo in grado di eseguire dei test con tutte le combinazioni possibili, in questa pagina si descrivono le configurazioni considerate come completamente supportate. Per la stabilire la compatibilità del sistema operativo, Red Hat® si basa sul processo di collaudo e certificazione delle JVM. Le seguenti famiglie di versioni di JVM, combinate a un sistema operativo che supporta la rispettiva JVM, sono considerate configurazioni pienamente supportate in un ambiente virtuale o reale.

JBoss Operations Network 3.1

Java Virtual Machine Versione
Oracle JDK 1.6.x
OpenJDK 1.6.x
IBM JDK 1.6.x

JBoss Operations Network 3.0

Java Virtual Machine Versione
Oracle JDK 1.6.x
OpenJDK 1.6.x
IBM JDK 1.6.x

JBoss Operations Network 2.4

Java Virtual Machine Versione
Oracle JDK 1.6.x, 1,5.x (obsolete)
OpenJDK 1.6.x, 1,5.x (obsolete)
IBM JDK 1.6.x, 1.5.x (obsolete)
Azul JDK 1.6.x, 1,5.x (obsolete)

JBoss ON è basato su librerie native per funzionalità specifiche relativamente alla gestione delle configurazioni Apache e alla gestione delle prestazioni per file system di CPU e dispositivi di rete. Ci saranno anche piattaforme su cui queste funzionalità non sono disponibili o non sono supportate. Le seguenti architetture di sistemi operativi e chip includono supporto nativo completo. Possono essere incluse librerie native per altri sistemi operativi e/o architetture, ma non sono supportate. L'elenco viene aggiornato periodicamente con le nuove configurazioni certificate. La dicitura "obsoleto" relativa al sistema operativo nativo nei dati sottostanti si riferisce al supporto nativo. Il sistema operativo potrebbe continuare a essere supportato con una JVM apposita.

JBoss Operations Network 3.1

Sistema operativo nativo Architettura dei chip
Red Hat Enterprise Linux 6 (aggiornamento più recente) x86, x86_64
Microsoft Windows 7 2008 x86, x86_64
Solaris 10 (obsoleto), 11 x86_64

JBoss Operations Network 3.0

Sistema operativo nativo Architettura dei chip
Red Hat Enterprise Linux 6 (aggiornamento più recente) x86, x86_64
Microsoft Windows 7 2008 x86, x86_64
Solaris 10 (obsoleto), 11 x86_64

JBoss Operations Network 2.4

Sistema operativo nativo Architettura dei chip
Red Hat Enterprise Linux 5 (ultimo aggiornamento) x86, x86_64
Red Hat Enterprise Linux 4 (ultimo aggiornamento) x86, x86_64
Microsoft Windows XP, 2000, Vista, 7 x86, x86_64
Solaris 10 (obsoleto) x86, x86_64, SPARC 64
HP-UX 11 (obsoleto) PA, Itanium
AIX 5.2 (obsoleto) 32 bit

JBoss ON offre un'interfaccia utente grafica basata su HTML. La tabella seguente indica quali browser sono stati certificati. Altri browser basati sullo stesso motore o su versioni più recenti potrebbero essere utilizzabili, ma il supporto non è garantito. Le versioni precedenti non sono supportate.

JBoss Operations Network 3.1

Browser Versione

Firefox

10
Internet Explorer 8

JBoss Operations Network 3.0

Browser Versione

Firefox

3.6.x, 4.x
Internet Explorer 8

JBoss Operations Network 2.4

Browser Versione
Firefox 2.x, 3.x
Internet Explorer 6 (obsoleta), 7 (obsoleta), 8

JBoss ON richiede un database con almeno 10 GB di storage per essere utilizzato in produzione. Sono supportati i seguenti database.

JBoss Operations Network 3.1

Database Versione
Oracle 11g R2, 11gR2 RAC, 11g R1, 11g R1 RAC, 10g R2, 10g R1
PostgreSQL 8.3.x, 8.4.x, 9.x

JBoss Operations Network 3.0

Database Versione
Oracle 11g R2, 11gR2 RAC, 11g R1, 11g R1 RAC, 10g R2, 10g R1
PostgreSQL 8.3.x, 8.4.x, 9.x

JBoss Operations Network 2.4

Database Versione
Oracle 11g R1, 11g R2, 10g R2, 10g R1
PostgreSQL 8.2.4 e versioni successive, 8.3.x, 8.4.x

JBoss ON offre prestazioni, configurazione e gestione di inventario per le risorse seguenti.

JBoss Operations Network 3.1

JBoss Enterprise Application Platform 4.2.x (obsoleto), 4.3.x (obsoleto), 5.x, 6.x
JBoss Enterprise SOA Platform (ESB) 4.3.x (obsoleto), 5.x
JBoss Enterprise Data Services Platform 5.x
JBoss Enterprise Web Platform 5.x
JBoss Enterprise Portal Platform 5.2.x
JBoss Enterprise BRMS 5.2.x
Server Web JBoss Enterprise Supporto non ancora disponibile
Apache 1.3.x, 2.x

JBoss Operations Network 3.0

JBoss Enterprise Application Platform 4.2.x, 4.3.x, 5.x
JBoss Enterprise SOA Platform (ESB) 4.3.x, 5.x
JBoss Enterprise Data Services Platform 5.x
JBoss Enterprise Web Platform 5.x
JBoss Enterprise Portal Platform 5.2.x
JBoss Enterprise BRMS 5.2.x
Server Web JBoss Enterprise 1.x
Apache 1.3.x, 2.x

JBoss Operations Network 2.4

JBoss Enterprise Application Platform 4.2.x, 4.3.x, 5.x
JBoss Enterprise SOA Platform (ESB) 4.3.x, 5.x
JBoss Enterprise Data Services Platform 5.x
JBoss Enterprise Web Platform 5.x
Server Web JBoss Enterprise 1.x
Apache 1.3.x, 2.x