Configuraciones soportadas de JBoss Operations Network

Actualizado -

NOTA: esta traducción puede no ser actual. Consulte la versión en inglés para obtener la información más actualizada.

Cada versión de JBoss® Operations Network (JBoss ON) se somete a pruebas y se certifica para su uso con diversas combinaciones de sistemas operativos, máquinas virtuales Java™ (JVM) y bases de datos líderes del mercado. Dado que no podemos probar todas las combinaciones posibles, esta página describe lo que nosotros consideramos configuraciones totalmente compatibles.

Red Hat® confía en el proceso de pruebas y certificación de la JVM para determinar la compatibilidad del sistema operativo. Las siguientes familias de versiones de JVM, en combinación con un sistema operativo que admita JVM, se consideran con pleno soporte en un entorno virtual o real.

JBoss Operations Network 3.1

Java Virtual Machine Versión
Oracle JDK 1.6.x
OpenJDK 1.6.x
IBM JDK 1.6.x

JBoss Operations Network 3.0

Java Virtual Machine Versión
Oracle JDK 1.6.x
OpenJDK 1.6.x
IBM JDK 1.6.x

JBoss Operations Network 2.4

Java Virtual Machine Versión
Oracle JDK 1.6.x, 1.5.x (desaprobado)
OpenJDK 1.6.x, 1.5.x (desaprobado)
IBM JDK 1,6.x, 1.5.x (desaprobado)
Azul JDK 1.6.x, 1.5.x (desaprobado)

JBoss ON depende de bibliotecas nativas para funcionalidades específicas relacionadas con la administración de configuración y rendimiento de Apache para sistemas de archivos de CPU y dispositivos de red. Como tal, puede existir plataformas en que estas funciones no están disponibles o son soportadas. Los siguientes sistemas operativos y arquitecturas de chip incluyen compatibilidad nativa completa. Es posible que se incluya bibliotecas nativas para otros sistemas operativos o arquitecturas, pero no son soportadas. Esta lista se actualiza a medida que se certifican configuraciones adicionales. La siguiente nota para el sistema operativo nativo que está desaprobado se refiere a soporte nativo. El sistema operativo en sí puede seguir siendo compatible con un JVM adecuado.

JBoss Operations Network 3.1

Sistema operativo nativo Arquitectura de chip
Red Hat Enterprise Linux 6 (actualización más reciente) x86, x86_64
Microsoft Windows 7, 2008 x86, x86_64
Solaris 10, (desaprobado), 11 x86_64

JBoss Operations Network 3.0

Sistema operativo nativo Arquitectura de chip
Red Hat Enterprise Linux 6 (actualización más reciente) x86, x86_64
Microsoft Windows 7, 2008 x86, x86_64
Solaris 10, (desaprobado), 11 x86_64

JBoss Operations Network 2.4

Sistema operativo nativo Arquitectura de chip
Red Hat Enterprise Linux 5 (actualización más reciente) x86, x86_64
Red Hat Enterprise Linux 4 (actualización más reciente) x86, x86_64
Microsoft Windows XP, 2000, Vista, 7 x86, x86_64
Solaris 10, (desaprobado) x86, x86_64, SPARC 64
HP-UX 11, (desaprobado) PA, Itanium
AIX 5.2, (desaprobado) 32 bits

JBoss ON ofrece una interfaz de gráfica de usuario basada en HTML La siguiente tabla indica los navegadores certificados. Es posible utilizar otros navegadores basados en el mismo motor o con versiones posteriores, pero no es seguro que sean soportados. Las versiones anteriores no son soportados.

JBoss Operations Network 3.1

Navegador Versión

Firefox

10
Internet Explorer 8

JBoss Operations Network 3.0

Navegador Versión

Firefox

3.6.x, 4.x
Internet Explorer 8

JBoss Operations Network 2.4

Navegador Versión
Firefox 2.x, 3.x
Internet Explorer 6 (desaprobado), 7 (desaprobado), 8

JBoss ON necesita una base de datos con al menos 10 GB de almacenamiento para utilizar en producción. Las siguientes bases de datos están soportadas:

JBoss Operations Network 3.1

Base de datos Versión
Oracle 11g R2, 11gR2 RAC, 11g R1, 11g R1 RAC, 10g R2, 10g R1
PostgreSQL 8.3.x, 8.4.x, 9.x

JBoss Operations Network 3.0

Base de datos Versión
Oracle 11g R2, 11gR2 RAC, 11g R1, 11g R1 RAC, 10g R2, 10g R1
PostgreSQL 8.3.x, 8.4.x, 9.x

JBoss Operations Network 2.4

Base de datos Versión
Oracle 11g R1, 11g R2, 10g R2, 10g R1
PostgreSQL 8.2.4 y posterior, 8.3.x, 8.4.x

JBoss ON ofrece administración de rendimiento, configuración e inventario para los siguientes recursos.

JBoss Operations Network 3.1

JBoss Enterprise Application Platform 4.2.x(desaprobado), 4.3.x(desaprobado), 5.x, 6.x
JBoss Enterprise SOA Platform (ESB) 4.3.x(desaprobado), 5.x
JBoss Enterprise Data Services Platform 5.x
JBoss Enterprise Web Platform 5.x
JBoss Enterprise Portal Platform 5.2.x
JBoss Enterprise BRMS 5.2.x
JBoss Enterprise Web Server Compatibilidad aún no disponible
Apache. 1.3.x, 2.x

JBoss Operations Network 3.0

JBoss Enterprise Application Platform 4.2.x, 4.3.x, 5.x
JBoss Enterprise SOA Platform (ESB) 4.3.x, 5.x
JBoss Enterprise Data Services Platform 5.x
JBoss Enterprise Web Platform 5.x
JBoss Enterprise Portal Platform 5.2.x
JBoss Enterprise BRMS 5.2.x
JBoss Enterprise Web Server 1.x
Apache. 1.3.x, 2.x

JBoss Operations Network 2.4

JBoss Enterprise Application Platform 4.2.x, 4.3.x, 5.x
JBoss Enterprise SOA Platform (ESB) 4.3.x, 5.x
JBoss Enterprise Data Services Platform 5.x
JBoss Enterprise Web Platform 5.x
JBoss Enterprise Web Server 1.x
Apache. 1.3.x, 2.x