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Abstract

This document details steps to install Red Hat Developer Studio Integration Stack.
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CHAPTER 1. INSTALLATION OPTIONS
Red Hat Developer Studio Integration Stack is provided as a set of plug-ins for Eclipse or
Developer Studio. Depending on whether you are already using Eclipse or Developer Studio, there are
a variety of ways of installing Developer Studio Integration Stack and instructions are given here for
each variation:

Chapter 4, Installing Developer Studio Integration Stack Using the Standalone Installer

Chapter 5, Installing Developer Studio Integration Stack in Eclipse when Online

Chapter 6, Installing Developer Studio Integration Stack in Eclipse when Offline

Chapter 7, Installing Developer Studio Integration Stack in Developer Studio when Online

Chapter 8, Installing Developer Studio Integration Stack in Developer Studio when Offline

NOTE

To install Eclipse, see https://eclipse.org/users/ on the Eclipse website. To install
Developer Studio in Eclipse or Developer Studio Stand-alone using the Installer, see the
Installation Guide for the relevant version on the Red Hat Developer Studio
documentation page.

IMPORTANT

A variety of Eclipse installations are available, each with a different default configuration
and selection of preinstalled plug-ins. Red Hat recommends using the Eclipse Oxygen for
Java EE Developers plug-in when using Developer Studio Integration Stack.

CHAPTER 1. INSTALLATION OPTIONS
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CHAPTER 2. SYSTEM REQUIREMENTS
This release of Developer Studio is supported for use with a range of operating system, architecture,
and Java developer kit combinations; for a complete list, see Supported Configurations and
Components on the Red Hat Customer Portal.

The requirements to install and run this release of Developer Studio are:

Recommended requirements:

4 GB RAM

2 GB of hard disk space

Minimum requirements:

2 GB RAM

1 GB of hard disk space.

Red Hat Developer Studio Integration Stack 12.0 Installation Guide
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CHAPTER 3. UPDATING DEVELOPER STUDIO
INTEGRATION STACK

Each major version of Developer Studio Integration Stack is based on a different version of Eclipse. As a
result, it is not possible to update an older major version of Developer Studio Integration Stack to a
newer major version. For example, it is not possible to update an existing Developer Studio
Integration Stack 11.x or earlier installation to Developer Studio Integration Stack 12.0. because
Developer Studio Integration Stack 11.x is based on Eclipse Oxygen (4.7) but Developer Studio
Integration Stack 12.0 is based on Eclipse Photon (4.8).

You can configure your IDE settings for automatic updates. The IDE then automatically notifies users
when an update for the next minor version is available, depending on your IDE settings for automatic
updates. To check for updates, click Help → Check for Updates .

CHAPTER 3. UPDATING DEVELOPER STUDIO INTEGRATION STACK
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CHAPTER 4. INSTALLING DEVELOPER STUDIO
INTEGRATION STACK USING THE STANDALONE INSTALLER

Use the standalone installer to install Developer Studio Integration Stack with all the latest versions of
the integration stack components:

Red Hat Developer Studio

Red Hat Business Process and Rules Management

Red Hat Fuse Tools

Red Hat Data Virtualization Development

To install Developer Studio Integration Stack using the Standalone Installer:

1. Download the Standalone Installer file from Developer Studio Software Downloads and run the
file.

2. Indicate agreement with the terms and conditions and then specify a target installation
directory and a target JDK for the installation.

3. Select the required components from the Select Additional Features to Install
screen:

Figure 4.1. Select Additional Features to Install

4. Click Next to continue the installation process until the process completes.

When complete, Developer Studio Integration Stack and the integration stack components are ready
to use.

Red Hat Developer Studio Integration Stack 12.0 Installation Guide
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CHAPTER 5. INSTALLING DEVELOPER STUDIO
INTEGRATION STACK IN ECLIPSE WHEN ONLINE

Developer Studio Integration Stack is available to install in Eclipse when you are online. Installing
these components also installs Developer Studio.

To install Developer Studio Integration Stack in Eclipse when online:

1. Start Eclipse Photon for Java EE Developers .

2. Click Help → Eclipse Marketplace, locate Red Hat Developer Studio Integration Stack  and
click Install.

3. Select the components to install:

a. For Red Hat Process Automation Manager, select Red Hat Business Process and Rules
Development (BPEL, BPMN2, jBPMS6, Drools).

b. For Red Hat Data Virtualization, select Red Hat Data Virtualization Development (Teiid
Designer).

4. Follow the on-screen instructions to complete the installation process.

During the installation process, warnings about installing unsigned content may display. If this is the
case, review the details of the content and if satisfied click OK to continue the installation.

WARNING

Restart the IDE to apply the changes. Until it is restarted, the changes may make
the IDE unstable.

Once installed, complete the additional configuration actions before you can use the Developer Studio
Integration Stack functionality. For plug-in specific configuration information, see the appropriate Red
Hat JBoss product documentation available from the Red Hat Customer Portal .



CHAPTER 5. INSTALLING DEVELOPER STUDIO INTEGRATION STACK IN ECLIPSE WHEN ONLINE
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CHAPTER 6. INSTALLING DEVELOPER STUDIO
INTEGRATION STACK IN ECLIPSE WHEN OFFLINE

To install Developer Studio Integration Stack in Eclipse when offline:

1. Locate and download the following files at Developer Studio Software Downloads:

a. Red Hat Developer Studio 12.0.0 Update Site Zip

b. Red Hat Developer Studio Integration Stack 12.0.0 Update Site Zip

2. Start Eclipse Photon for Java EE Developers .

3. Click Window → Preferences → Install/Update → Available Software Sites .

4. Click Add, click Archive to locate the Developer Studio Update .zip file, select the file and
click Add.

5. Click Apply and Close again to close the Preferences window.

6. Click Help → Install New Software .

7. Next to the Work with field, click Add and click Archive to locate the Red Hat Developer
Studio Integration Stack 12.0.0 Update Site Zip file.

8. From the table of categories, select the Developer Studio Integration Stack functionality you
want to install:

a. For Red Hat Process Automation Manager, select Red Hat Business Process and Rules
Development (BPEL, BPMN2, jBPMS6, Drools).

b. For Red Hat Data Virtualization, select Red Hat Data Virtualization Development (Teiid
Designer).

9. Click Next.

10. Follow the on-screen instructions to complete the installation process.

During the installation process, you may receive warnings about installing unsigned content. If this is
the case, review the details of the content and if satisfied click OK to continue with the installation.

Once installation is complete, you are prompted to restart the IDE. Click Yes when any changes to
open projects are saved and you are ready to restart the IDE immediately. If the IDE is not restarted,
the unapplied changes can make the IDE unstable.

Red Hat Developer Studio Integration Stack 12.0 Installation Guide
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CHAPTER 7. INSTALLING DEVELOPER STUDIO
INTEGRATION STACK IN DEVELOPER STUDIO WHEN ONLINE

Developer Studio Integration Stack is available to install from Developer Studio, through Red Hat
Central Software/Update tab, when online.

IMPORTANT

Before using the following instructions to install Developer Studio Integration Stack,
ensure that Developer Studio is installed. For detailed steps to install Developer Studio,
see Install Red Hat Developer Studio.

To install Developer Studio Integration Stack in Developer Studio when online:

1. Start Developer Studio 12.0.

2. In Red Hat Central, click the Software/Update tab. If Red Hat Central is not visible, click Help
→ Red Hat Central .

3. In the list of available software, locate Developer Studio Integration Stack.

4. Select the check boxes corresponding to the Developer Studio Integration Stack functionality
you want to install:

a. For Red Hat Process Automation Manager, select Red Hat Business Process and Rules
Development (BPEL, BPMN2, jBPMS6, Drools).

b. For Red Hat Data Virtualization, select Red Hat Data Virtualization Development (Teiid
Designer).

5. Click Install/Update.

6. Follow the on-screen instructions to complete the installation process.

Restart the IDE to apply the changes. Until it is restarted, the changes may make the IDE unstable.

Once installed, you may need to complete additional configuration actions before you can use the
Developer Studio Integration Stack functionality. For plug-in specific configuration information, see
the appropriate Red Hat JBoss product documentation available from the Red Hat Customer Portal .

IMPORTANT

If you install only selected functionalities from a Developer Studio Integration Stack
category, then the category continues to be listed as uninstalled in the Red Hat Central
Software/Update tab.

CHAPTER 7. INSTALLING DEVELOPER STUDIO INTEGRATION STACK IN DEVELOPER STUDIO WHEN ONLINE
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CHAPTER 8. INSTALLING DEVELOPER STUDIO
INTEGRATION STACK IN DEVELOPER STUDIO WHEN OFFLINE

IMPORTANT

To install Developer Studio Integration Stack as detailed in the steps below, it is
essential that you have an instance of Developer Studio installed. For detailed steps to
install Developer Studio, see Install Red Hat Developer Studio.

To install Developer Studio Integration Stack in Developer Studio when offline:

1. Locate and download the Red Hat Developer Studio Integration Stack 12.0.0 Update Site Zip
file from Developer Studio Software Downloads.

2. Start Developer Studio 12.0.

3. Click Help → Install New Software .

4. Next to the Work with field, click Add and click Archive to locate the Red Hat Developer
Studio Integration Stack 12.0.0 Update Site Zip file.

5. From the table of categories, select the Developer Studio Integration Stack functionality you
want to install:

a. For Red Hat Process Automation Manager, select Red Hat Business Process and Rules
Development (BPEL, BPMN2, jBPMS6, Drools).

b. For Red Hat Data Virtualization, select Red Hat Data Virtualization Development (Teiid
Designer).

6. Click Next.

7. Follow the on-screen instructions to complete the installation process.

During the installation process, you may receive warnings about installing unsigned content. If this is
the case, review the details of the content and if satisfied click OK to continue with the installation.

Once installation is complete, you are prompted to restart the IDE. Click Yes when any changes to
open projects are saved and you are ready to restart the IDE immediately. Unapplied IDE changes can
cause instability if the IDE is not restarted.

Red Hat Developer Studio Integration Stack 12.0 Installation Guide
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CHAPTER 9. UNINSTALLATION OPTIONS
After concluding development in one of the Red Hat Developer Studio Integration Stack tooling plug-
ins, you can choose to uninstall either an entire category of plug-ins or individual plug-ins. Removing
plug-ins that are no longer required provides continued stability and ensures optimal performance due
to a smaller memory footprint. Uninstall a category of features to remove all related features
efficiently, or select individual plug-ins to remove in a customized uninstall process.

To uninstall an entire category of features, see Section 9.1, “Uninstalling an Entire Category of
Developer Studio Integration Stack”.

To uninstall a single feature, see Section 9.2, “Uninstalling a Single Feature of Developer Studio
Integration Stack”.

9.1. UNINSTALLING AN ENTIRE CATEGORY OF DEVELOPER STUDIO
INTEGRATION STACK

To uninstall an entire category of Developer Studio Integration Stack:

1. In Red Hat Central, click the Software/Update tab.

NOTE

If Red Hat Central is not visible, click Help → Red Hat Central .

2. Click the Show installed check box.

3. In the Features Available  list, locate Developer Studio Integration Stack.

4. Select the check boxes corresponding to the Developer Studio Integration Stack category to
uninstall:

a. For Red Hat Process Automation Manager, select Red Hat Business Process and Rules
Development (BPEL, BPMN2, jBPMS6, Drools).

b. For Red Hat Data Virtualization, select Red Hat Data Virtualization Development (Teiid
Designer).

5. Click Uninstall.

6. Follow the on-screen instructions to complete the process of uninstalling the selected
category.

7. Restart the IDE to implement the changes. An immediate restart is recommended because the
IDE may be unstable until a restart.

9.2. UNINSTALLING A SINGLE FEATURE OF DEVELOPER STUDIO
INTEGRATION STACK

To uninstall a single feature of Developer Studio Integration Stack:

1. Click Help → Installation Details.

2. In the search field type the feature to uninstall.

CHAPTER 9. UNINSTALLATION OPTIONS
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3. Click the feature to uninstall and click Uninstall.

NOTE

To delete more than one feature select the features while you press the Shift
key.

4. Follow the on-screen instructions to complete the process of uninstalling the selected feature.

5. Restart the IDE to implement the changes. An immediate restart is recommended because the
IDE may be unstable until a restart.

Red Hat Developer Studio Integration Stack 12.0 Installation Guide
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