7.6. 配置 Juniper EX 系列交换机

7.6.1. 关于中继端口

通过 OpenStack 网络,您可以将实例连接到物理网络上已存在的 VLAN。术语 trunk 用于描述允许多个 VLAN 遍历同一端口的端口。通过使用这些端口,VLAN 可以跨越多个交换机,包括虚拟交换机。例如,在物理网络中标记为 VLAN110 的流量到达 Compute 节点,其中 8021q 模块将标记的流量定向到 vSwitch 上的相应 VLAN。

7.6.2. 为 Juniper EX 系列交换机配置中继端口

流程

  • 如果使用运行 Juniper JunOS 的 Juniper EX 系列交换机,请使用以下配置语法来允许 VLAN 110 和 111 的流量传递到您的实例。

    此配置假设您的物理节点有一个以太网电缆连接到物理交换机上的 ge-1/0/12 接口。

    重要

    这些值是示例。您必须更改此示例中的值,使其与环境中的值匹配。在不调整的情况下将这些值复制并粘贴到交换机配置中可能会导致意外中断。

     ge-1/0/12 {
              description Trunk to Compute Node;
                  unit 0 {
                      family ethernet-switching {
                          port-mode trunk;
                          vlan {
                              members [110 111];
                               }
                          native-vlan-id 2;
                      }
                  }
    }

7.6.3. 关于访问端口

不是 Compute 节点上的所有 NIC 都传输实例流量,因此您不需要配置所有 NIC 以允许多个 VLAN 传递。访问端口只需要一个 VLAN,并可能满足其他操作要求,如传输管理流量或块存储数据。这些端口通常称为访问端口,通常需要配置比中继端口更简单。

7.6.4. 为 Juniper EX 系列交换机配置访问端口

此示例为 Juniper EX 系列开关,显示 ge-1/0/13 作为 eth1 的访问端口。

+

重要

这些值是示例。您必须更改此示例中的值,使其与环境中的值匹配。在不调整的情况下将这些值复制并粘贴到交换机配置中可能会导致意外中断。

流程

此配置假设您的物理节点有一个以太网电缆连接到物理交换机上的 ge-1/0/13 接口。

+

 ge-1/0/13 {
          description Access port for Compute Node
              unit 0 {
                  family ethernet-switching {
                      port-mode access;
                      vlan {
                          members 200;
                           }
                      native-vlan-id 2;
                  }
              }
}

7.6.5. 关于 LACP 端口聚合

您可以使用链路聚合控制协议(LACP)将多个物理 NIC 捆绑在一起,以形成单个逻辑频道。LACP 也称为 802.3ad (或 Linux 中的绑定模式 4),LACP 为负载平衡和容错创建动态绑定。您必须在两个物理端配置 LACP:物理 NIC 和物理交换机端口上。

其他资源

7.6.6. 在物理 NIC 上配置 LACP

您可以在物理 NIC 上配置链路聚合控制协议(LACP)。

流程

  1. 编辑 /home/stack/network-environment.yaml 文件:

    - type: linux_bond
      name: bond1
      mtu: 9000
      bonding_options:{get_param: BondInterfaceOvsOptions};
      members:
        - type: interface
          name: nic3
          mtu: 9000
          primary: true
        - type: interface
          name: nic4
          mtu: 9000
  2. 将 Open vSwitch 网桥配置为使用 LACP:

    BondInterfaceOvsOptions:
        "mode=802.3ad"

7.6.7. 为 Juniper EX 系列交换机配置 LACP

在本例中,Compute 节点有两个使用 VLAN 100 的 NIC。

流程

  1. 物理将 Compute 节点的两个 NIC 连接到交换机(例如,端口 12 和 13)。
  2. 创建端口聚合:

    chassis {
        aggregated-devices {
            ethernet {
                device-count 1;
            }
        }
    }
  3. 配置交换机端口 12 (ge-1/0/12)和 13 (ge-1/0/13)以加入端口聚合 ae1

    interfaces {
        ge-1/0/12 {
            gigether-options {
                802.3ad ae1;
            }
        }
        ge-1/0/13 {
            gigether-options {
                802.3ad ae1;
                }
            }
    }
    注意

    对于 Red Hat OpenStack Platform director 部署,若要从绑定进行 PXE 引导,您必须将其中一个绑定成员配置为 lacp 强制,以确保在内省和第一次引导过程中只有一个绑定成员上线。使用 lacp force-up 配置的绑定成员必须是在 instackenv.json ( ironic 已知的 MAC 地址配置)中 MAC 地址的相同绑定成员。

  4. 在端口聚合 ae1 上启用 LACP:

    interfaces {
        ae1 {
            aggregated-ether-options {
                lacp {
                    active;
                }
            }
        }
    }
  5. 将聚合 ae1 添加到 VLAN 100:

    interfaces {
        ae1 {
            vlan-tagging;
            native-vlan-id 2;
            unit 100 {
                vlan-id 100;
            }
        }
    }
  6. 检查您的新端口频道。生成的输出列出了带有成员端口 ge-1/0/12ge-1/0/13 的新端口聚合 ae1

    > show lacp statistics interfaces ae1
    
    Aggregated interface: ae1
    LACP Statistics: LACP Rx LACP Tx Unknown Rx Illegal Rx
    ge-1/0/12 0 0 0 0
    ge-1/0/13 0 0 0 0
    注意

    记住通过运行 commit 命令应用您的更改。

7.6.8. 关于 MTU 设置

您必须调整某些类型的网络流量的 MTU 大小。例如,某些 NFS 或 iSCSI 流量需要巨型帧 (9000 字节)。

注意

您必须更改流量预期通过的所有跃点(包括任何虚拟交换机)的端到端的 MTU 设置。

7.6.9. 为 Juniper EX 系列交换机配置 MTU 设置

这个示例在 Juniper EX4200 交换机中启用巨型帧。

注意

根据您使用 Juniper 还是 Cisco 设备,MTU 值的计算方式不同。例如,对于 Cisco,Juniper 上的 9216 将等于 9202。额外的字节用于 L2 标头,其中 Cisco 会自动将此设置添加到指定的 MTU 值中,但可用的 MTU 将小于使用 Juniper 时指定的 14 字节。为了支持 VLAN 上的 MTU 9000,必须在 Juniper 上配置 9014 的 MTU。

流程

  1. 对于 Juniper EX 系列交换机,为各个接口设置 MTU 设置。这些命令在 ge-1/0/14ge-1/0/15 端口上配置巨型帧:

    set interfaces ge-1/0/14 mtu 9216
    set interfaces ge-1/0/15 mtu 9216
    注意

    记住通过运行 commit 命令保存您的更改。

  2. 如果使用 LACP 聚合,则需要在其中设置 MTU 大小,而不是在成员 NIC 中设置 MTU。例如,此设置配置 ae1 聚合的 MTU 大小:

     set interfaces ae1 mtu 9216

7.6.10. 关于 LLDP 发现

ironic-python-agent 服务侦听来自连接的交换机的 LLDP 数据包。收集的信息可以包含交换机名称、端口详细信息和可用的 VLAN。与 Cisco Discovery Protocol (CDP) 类似,LLDP 有助于在 director 内省过程中发现物理硬件。

7.6.11. 为 Juniper EX 系列交换机配置 LLDP

您可以为所有接口或只为单个接口启用 LLDP。

流程

  • 在 Juniper EX 4200 交换机上,使用以下太全局启用 LLDP:

    lldp {
    	interface all{
    		enable;
    	}
    	}
    }
  • 使用以下内容为单一接口 ge-1/0/14 启用 LLDP:

    lldp {
    	interface ge-1/0/14{
    		enable;
    	}
    	}
    }
    注意

    记住通过运行 commit 命令应用您的更改。