7.3. 配置 Cisco Nexus 交换机

7.3.1. 关于中继端口

通过 OpenStack 网络,您可以将实例连接到物理网络上已存在的 VLAN。术语 trunk 用于描述允许多个 VLAN 遍历同一端口的端口。通过使用这些端口,VLAN 可以跨越多个交换机,包括虚拟交换机。例如,在物理网络中标记为 VLAN110 的流量到达 Compute 节点,其中 8021q 模块将标记的流量定向到 vSwitch 上的相应 VLAN。

7.3.2. 为 Cisco Nexus 交换机配置中继端口

  • 如果使用 Cisco Nexus,您可以使用以下配置语法来允许 VLAN 110 和 111 的流量传递到您的实例。

    此配置假设您的物理节点有一个以太网电缆连接到物理交换机上的 Ethernet1/12 接口。

    重要

    这些值是示例。您必须更改此示例中的值,使其与环境中的值匹配。在不调整的情况下将这些值复制并粘贴到交换机配置中可能会导致意外中断。

    interface Ethernet1/12
      description Trunk to Compute Node
      switchport mode trunk
      switchport trunk allowed vlan 2,110,111
      switchport trunk native vlan 2
    end

7.3.3. 关于访问端口

不是 Compute 节点上的所有 NIC 都传输实例流量,因此您不需要配置所有 NIC 以允许多个 VLAN 传递。访问端口只需要一个 VLAN,并可能满足其他操作要求,如传输管理流量或块存储数据。这些端口通常称为访问端口,通常需要配置比中继端口更简单。

7.3.4. 为 Cisco Nexus 交换机配置访问端口

流程

  • 使用 图 7.1 “网络布局示例” 图中的示例,Ethernet1/13 (在 Cisco Nexus 交换机上)配置为 eth1 的访问端口。此配置假设您的物理节点有一个以太网电缆连接到物理交换机上的 Ethernet1/13 接口。

    重要

    这些值是示例。您必须更改此示例中的值,使其与环境中的值匹配。在不调整的情况下将这些值复制并粘贴到交换机配置中可能会导致意外中断。

    interface Ethernet1/13
     description Access port for Compute Node
     switchport mode access
     switchport access vlan 200

7.3.5. 关于 LACP 端口聚合

您可以使用链路聚合控制协议(LACP)将多个物理 NIC 捆绑在一起,以形成单个逻辑频道。LACP 也称为 802.3ad (或 Linux 中的绑定模式 4),LACP 为负载平衡和容错创建动态绑定。您必须在两个物理端配置 LACP:物理 NIC 和物理交换机端口上。

其他资源

7.3.6. 在物理 NIC 上配置 LACP

您可以在物理 NIC 上配置链路聚合控制协议(LACP)。

流程

  1. 编辑 /home/stack/network-environment.yaml 文件:

    - type: linux_bond
      name: bond1
      mtu: 9000
      bonding_options:{get_param: BondInterfaceOvsOptions};
      members:
        - type: interface
          name: nic3
          mtu: 9000
          primary: true
        - type: interface
          name: nic4
          mtu: 9000
  2. 将 Open vSwitch 网桥配置为使用 LACP:

    BondInterfaceOvsOptions:
        "mode=802.3ad"

7.3.7. 为 Cisco Nexus 交换机配置 LACP

在本例中,Compute 节点有两个使用 VLAN 100 的 NIC:

流程

  1. 物理地将 Compute 节点 NIC 连接到交换机(例如,端口 12 和 13)。
  2. 确认 LACP 已启用:

    (config)# show feature | include lacp
    lacp                  1         enabled
  3. 将端口 1/12 和 1/13 配置为访问端口,以及作为频道组的成员。

    根据您的部署,您可以部署中继接口而不是访问接口。

    例如,对于 Cisco UCI,NIC 是虚拟接口,因此您可能需要单独配置访问端口。这些接口通常包含 VLAN 标记配置。

    interface Ethernet1/13
     description Access port for Compute Node
     switchport mode access
     switchport access vlan 200
     channel-group 10 mode active
    
    interface Ethernet1/13
     description Access port for Compute Node
     switchport mode access
     switchport access vlan 200
     channel-group 10 mode active
注意

当您使用 PXE 在 Cisco 交换机上置备节点时,您可能需要设置选项 no lacp graceful-convergenceno lacp suspend-individual 来调出端口并引导服务器。如需更多信息,请参阅 Cisco 交换机文档。

7.3.8. 关于 MTU 设置

您必须调整某些类型的网络流量的 MTU 大小。例如,某些 NFS 或 iSCSI 流量需要巨型帧 (9000 字节)。

注意

您必须更改流量预期通过的所有跃点(包括任何虚拟交换机)的端到端的 MTU 设置。

7.3.9. 为 Cisco Nexus 7000 交换机配置 MTU 设置

将 MTU 设置应用到 7000 系列交换机上的单个接口。

流程

  • 运行以下命令将接口 1/12 配置为使用 9000 字节的巨型帧:

    interface ethernet 1/12
      mtu 9216
      exit

7.3.10. 关于 LLDP 发现

ironic-python-agent 服务侦听来自连接的交换机的 LLDP 数据包。收集的信息可以包含交换机名称、端口详细信息和可用的 VLAN。与 Cisco Discovery Protocol (CDP) 类似,LLDP 有助于在 director 内省过程中发现物理硬件。

7.3.11. 为 Cisco Nexus 7000 交换机配置 LLDP

流程

  • 您可以为 Cisco Nexus 7000-series 交换机上的单个接口启用 LLDP:

    interface ethernet 1/12
      lldp transmit
      lldp receive
      no lacp suspend-individual
      no lacp graceful-convergence
    
    interface ethernet 1/13
      lldp transmit
      lldp receive
      no lacp suspend-individual
      no lacp graceful-convergence
注意

请注意,需要将 running-config 复制到 startup-config 以保持变化:copy running-config startup-config