7.2. 配置 Cisco Catalyst 交换机

7.2.1. 关于中继端口

通过 OpenStack 网络,您可以将实例连接到物理网络上已存在的 VLAN。术语 trunk 用于描述允许多个 VLAN 遍历同一端口的端口。通过使用这些端口,VLAN 可以跨越多个交换机,包括虚拟交换机。例如,在物理网络中标记为 VLAN110 的流量到达 Compute 节点,其中 8021q 模块将标记的流量定向到 vSwitch 上的相应 VLAN。

7.2.2. 为 Cisco Catalyst 交换机配置中继端口

  • 如果使用运行 Cisco IOS 的 Cisco Catalyst 交换机,您可以使用以下配置语法来允许 VLAN 110 和 111 的流量传递到您的实例。

    在此配置中,假定您的物理节点有一个以太网电缆连接到物理交换机上的 GigabitEthernet1/0/12 接口 GigabitEthernet1/0/12。

    重要

    这些值是示例。您必须更改此示例中的值,使其与环境中的值匹配。在不调整的情况下将这些值复制并粘贴到交换机配置中可能会导致意外中断。

    interface GigabitEthernet1/0/12
      description Trunk to Compute Node
      spanning-tree portfast trunk
      switchport trunk encapsulation dot1q
      switchport mode trunk
      switchport trunk native vlan 2
      switchport trunk allowed vlan 2,110,111

    使用以下列表了解这些参数:

    字段描述

    interface GigabitEthernet1/0/12

    X 节点连接的交换机端口。确保将 GigabitEthernet1/0/12 值替换为您的环境的正确端口值。使用 show interface 命令查看端口列表。

    描述 Trunk 到 Compute 节点

    一个唯一的具有描述性的值,可用于识别此接口。

    生成树端口快速中继

    如果您的环境使用 STP,则将此值设置为指示此端口用于中继流量的 Port Fast。

    switchport 中继封装点1q

    启用 802.1q 中继标准(而不是 ISL)。此值因交换机支持的配置而异。

    switchport 模式中继

    将此端口配置为中继端口,而不是访问端口,这意味着它允许 VLAN 流量传递给虚拟交换机。

    switchport 中继原生 vlan 2

    设置原生 VLAN,以指示发送未标记(非 VLAN)流量的交换机。

    switchport trunk allowed vlan 2,110,111

    定义通过中继允许哪些 VLAN。

7.2.3. 关于访问端口

不是 Compute 节点上的所有 NIC 都传输实例流量,因此您不需要配置所有 NIC 以允许多个 VLAN 传递。访问端口只需要一个 VLAN,并可能满足其他操作要求,如传输管理流量或块存储数据。这些端口通常称为访问端口,通常需要配置比中继端口更简单。

7.2.4. 为 Cisco Catalyst 交换机配置访问端口

  • 使用 图 7.1 “网络布局示例” 图中的示例,GigabitEthernet1/0/13 (在 Cisco Catalyst 交换机上)被配置为 eth1 的访问端口。

    在此配置中,您的物理节点有一个以太网电缆连接到物理交换机上的 GigabitEthernet1/0/12 接口 GigabitEthernet1/0/12。

    重要

    这些值是示例。您必须更改此示例中的值,使其与环境中的值匹配。在不调整的情况下将这些值复制并粘贴到交换机配置中可能会导致意外中断。

    interface GigabitEthernet1/0/13
     description Access port for Compute Node
     switchport mode access
     switchport access vlan 200
     spanning-tree portfast

    这些设置如下所述:

    字段描述

    interface GigabitEthernet1/0/13

    X 节点连接的交换机端口。确保将 GigabitEthernet1/0/12 值替换为您的环境的正确端口值。使用 show interface 命令查看端口列表。

    Compute 节点的描述访问端口

    一个唯一的具有描述性的值,可用于识别此接口。

    switchport 模式访问

    将此端口配置为访问端口,而不是中继端口。

    switchport 访问 vlan 200

    配置端口,以允许 VLAN 200 上的流量。您必须使用此 VLAN 中的 IP 地址配置 Compute 节点。

    acrossing-tree portfast

    如果使用 STP,则将此值设置为指示 STP 不尝试将其初始化为中继,从而在初始连接期间允许更快的端口握手(如服务器重启)。

7.2.5. 关于 LACP 端口聚合

您可以使用链路聚合控制协议(LACP)将多个物理 NIC 捆绑在一起,以形成单个逻辑频道。LACP 也称为 802.3ad (或 Linux 中的绑定模式 4),LACP 为负载平衡和容错创建动态绑定。您必须在两个物理端配置 LACP:物理 NIC 和物理交换机端口上。

其他资源

7.2.6. 在物理 NIC 上配置 LACP

您可以在物理 NIC 上配置链路聚合控制协议(LACP)。

流程

  1. 编辑 /home/stack/network-environment.yaml 文件:

    - type: linux_bond
      name: bond1
      mtu: 9000
      bonding_options:{get_param: BondInterfaceOvsOptions};
      members:
        - type: interface
          name: nic3
          mtu: 9000
          primary: true
        - type: interface
          name: nic4
          mtu: 9000
  2. 将 Open vSwitch 网桥配置为使用 LACP:

    BondInterfaceOvsOptions:
        "mode=802.3ad"

7.2.7. 为 Cisco Catalyst 交换机配置 LACP

在本例中,Compute 节点有两个使用 VLAN 100 的 NIC:

流程

  1. 在 Compute 节点上物理将 Compute 节点上的 NIC 连接到交换机(例如,端口 12 和 13)。
  2. 创建 LACP 端口频道:

    interface port-channel1
      switchport access vlan 100
      switchport mode access
      spanning-tree guard root
  3. 配置交换机端口 12 (Gi1/0/12)和 13 (Gi1/0/13):

    sw01# config t
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    sw01(config) interface GigabitEthernet1/0/12
       switchport access vlan 100
       switchport mode access
       speed 1000
       duplex full
       channel-group 10 mode active
       channel-protocol lacp
    
    interface GigabitEthernet1/0/13
      switchport access vlan 100
      switchport mode access
      speed 1000
      duplex full
      channel-group 10 mode active
      channel-protocol lacp
  4. 检查您的新端口频道。生成的输出列出了新 port-channel Po1,成员端口 Gi1/0/12Gi1/0/13

    sw01# show etherchannel summary
    <snip>
    
    Number of channel-groups in use: 1
    Number of aggregators:           1
    
    Group  Port-channel  Protocol    Ports
    ------+-------------+-----------+-----------------------------------------------
    1      Po1(SD)         LACP      Gi1/0/12(D)  Gi1/0/13(D)
    注意

    请注意,需要将 running-config 复制到 startup-config 以使变化生效:copy running-config startup-config

7.2.8. 关于 MTU 设置

您必须调整某些类型的网络流量的 MTU 大小。例如,某些 NFS 或 iSCSI 流量需要巨型帧 (9000 字节)。

注意

您必须更改流量预期通过的所有跃点(包括任何虚拟交换机)的端到端的 MTU 设置。

7.2.9. 为 Cisco Catalyst 交换机配置 MTU 设置

完成本示例流程中的步骤,在 Cisco Catalyst 3750 交换机上启用巨型帧。

  1. 查看当前的 MTU 设置:

    sw01# show system mtu
    
    System MTU size is 1600 bytes
    System Jumbo MTU size is 1600 bytes
    System Alternate MTU size is 1600 bytes
    Routing MTU size is 1600 bytes
  2. 在 3750 交换机上更改 MTU 设置,而不是针对各个接口更改。运行以下命令,将交换机配置为使用 9000 字节的巨型帧。如果您的交换机支持此功能,您可能希望为单个接口配置 MTU 设置。

    sw01# config t
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    sw01(config)# system mtu jumbo 9000
    Changes to the system jumbo MTU will not take effect until the next reload is done
    注意

    请注意,需要将 running-config 复制到 startup-config 以保持变化:copy running-config startup-config

  3. 重新加载交换机以应用更改。

    重要

    重新加载交换机会导致对依赖于交换机的任何设备造成网络中断。因此,仅在计划的维护期间重新加载交换机。

    sw01# reload
    Proceed with reload? [confirm]
  4. 重新加载交换机后,确认新的巨型 MTU 大小。

    具体输出可能会因交换机模型而异。例如,系统 MTU 可能适用于非Gigabit 接口,Jumbo MTU 可能会描述所有 Gigabit 接口。

    sw01# show system mtu
    
    System MTU size is 1600 bytes
    System Jumbo MTU size is 9000 bytes
    System Alternate MTU size is 1600 bytes
    Routing MTU size is 1600 bytes

7.2.10. 关于 LLDP 发现

ironic-python-agent 服务侦听来自连接的交换机的 LLDP 数据包。收集的信息可以包含交换机名称、端口详细信息和可用的 VLAN。与 Cisco Discovery Protocol (CDP) 类似,LLDP 有助于在 director 内省过程中发现物理硬件。

7.2.11. 为 Cisco Catalyst 交换机配置 LLDP

流程

  1. 运行 lldp run 命令,在您的 Cisco Catalyst 交换机上全局启用 LLDP:

    sw01# config t
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    sw01(config)# lldp run
  2. 查看任何与 LLDP 兼容的设备:

    sw01# show lldp neighbor
    Capability codes:
        (R) Router, (B) Bridge, (T) Telephone, (C) DOCSIS Cable Device
        (W) WLAN Access Point, (P) Repeater, (S) Station, (O) Other
    
    Device ID           Local Intf     Hold-time  Capability      Port ID
    DEP42037061562G3     Gi1/0/11       180        B,T             422037061562G3:P1
    
    Total entries displayed: 1
注意

请注意,需要将 running-config 复制到 startup-config 以保持变化:copy running-config startup-config