Menu Close
Settings Close

Language and Page Formatting Options

4.10. 在启用了 DevWorkspace 引擎时升级一个 CodeReady Workspaces 2.15 实例(技术预览)

与管理指南中所述的 升级过程 相比,使用 DevWorkspace 引擎(技术预览)升级一个 CodeReady Workspaces 2.15 实例要简单得多。

临时解决方案

  1. 跳过 升级过程中的第 1 步和第 2 步
  2. 升级步骤 5 步,在为迁移脚本设置环境变量时,使用以下两个值:

    • export PRE_MIGRATION_PRODUCT_SUBSCRIPTION_NAME=codeready-workspaces2,而不是记录 的代码ready-workspaces
    • 导出 PRE_MIGRATION_PRODUCT_OPERATOR_NAMESPACE=openshift-operators,而不是记录的 openshift-workspaces
  3. 升级过程 的第 6 步,仅运行 ./3-subscribe.sh./4-wait.sh 脚本。不要运行 ./1-prepare.sh./2-migrate.sh
重要

从 OpenShift Container Platform 4.10 开始,支持使用 DevWorkspace 引擎部署 OpenShift Dev Spaces 3.0。管理员必须先将运行早期版本的 OpenShift Container Platform 的集群升级到 4.10 或更高版本,然后才能订阅和部署 OpenShift Dev Spaces。

其他资源