第 8 章 已知问题

参考JBoss EAP 7.1.0 已知问题可查看本发行版本中已知问题的列表。

此外,需要注意以下问题:

  • jboss-jaxrpc-api_1.1_spec 软件包会在 JBoss EAP licenses.xml 文件中列出不正确的许可证。正确的许可证信息是 CDDL具有 with the Classpath 例外的 GPLv2
  • RPM 和 ZIP 安装的工件许可证之间存在一些差异。ZIP 安装中的许可证信息有效,但在上一条目中提到的 jboss-jaxrpc-api_1.1_spec 软件包许可证信息除外。
  • 尝试将类型为 PKCS12 的凭证库用于 IBM JDK 或 HP JDK 时会出现问题。解决办法是使用 JCEKS 凭证库。更多信息请参考 JBEAP-13586
  • 以下 JIRA 是由 JDK 程序错误导致的,修复这些问题超出了 JBoss EAP 的范围:

    • JBEAP-8207:使用 Elytron、IBM java、SPNEGO 时出现 "continuation required" 情况
    • JBEAP-10483:HTTP2 via JSSE 和 wildfly ALPN hack ssl engine 在 Solaris 11 上出现故障

      JBoss EAP 解决此问题的方法是在默认 JBoss EAP 配置中禁用 OracleUcrypto 提供程序。但是,这样做可能导致在 Solaris 10 平台上使用 HTTP over TLS 时出现问题。如果遇到这种问题,或者启用 OracleUcrypto 提供程序,或者使用 150401-52 补丁或更新的补丁程序来更新 Solaris 10 计算机。





Revised on 2018-01-11 04:54:10 EST