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Abstract
This document details steps to install Red Hat JBoss Developer Studio Integration Stack.
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CHAPTER 1. INSTALLATION OPTIONS

Red Hat JBoss Developer Studio Integration Stack is provided as a set of plug-ins for Eclipse or
JBoss Developer Studio. Depending on whether you are already using Eclipse or
JBoss Developer Studio, there are a variety of ways of installing JBoss Developer Studio
Integration Stack and instructions are given here for each variation:

Chapter 4, Installing JBoss Developer Studio Integration Stack Using the Standalone Installer

Chapter 5, Installing JBoss Developer Studio Integration Stack in Eclipse when Online

Chapter 6, Installing JBoss Developer Studio Integration Stack in Eclipse when Offline

Chapter 7, Installing JBoss Developer Studio Integration Stack in JBoss Developer Studio when
Online

Chapter 8, Installing JBoss Developer Studio Integration Stack in JBoss Developer Studio when
Offline

Note

To install Eclipse, see https://eclipse.org/users/ on the Eclipse website. To install
JBoss Developer Studio BYOE or standalone, see the Install Red Hat
JBoss Developer Studio document for the relevant version on the Red Hat
JBoss Developer Studio documentation page.

Important

A variety of Eclipse installations are available, each with a different default configuration
and selection of pre-installed plug-ins. For using JBoss Developer Studio
Integration Stack, it is recommended that you use the variant Eclipse Neon for Java EE
Developers.

CHAPTER 1. INSTALLATION OPTIONS
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CHAPTER 2. SYSTEM REQUIREMENTS

This release of JBoss Developer Studio is supported for use with a range of operating system,
architecture, and Java developer kit combinations; for a complete list, see Red Hat
JBoss Developer Studio Supported Configurations and Components on the Red Hat Customer
Portal.

To install and run this release of JBoss Developer Studio, the following memory requirements are
recommended:

4 GB RAM

2 GB of hard disk space

Note

The minimum memory requirements are 2 GB RAM and 1 GB of hard disk space.

Red Hat JBoss Developer Studio Integration Stack 10.0 Installation Guide
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CHAPTER 3. UPDATING JBOSS DEVELOPER STUDIO
INTEGRATION STACK

Each major version of JBoss Developer Studio Integration Stack is based on a different version of
Eclipse. As a result, it is not possible to update an older major version of JBoss Developer Studio
Integration Stack to a newer major version. For example, it is not possible to update an existing
JBoss Developer Studio Integration Stack 9.x or earlier installation to JBoss Developer Studio
Integration Stack 10.x. because JBoss Developer Studio Integration Stack 9.x is based on Eclipse
Mars (4.5) but JBoss Developer Studio Integration Stack 10.x is based on Eclipse Neon (4.6).

No updates are available for the first major version of JBoss Developer Studio Integration Stack,
such as version 10.0. For subsequent 10.x versions, you may be automatically notified by the IDE
when an update for the next minor version is available, depending on your IDE settings for automatic
updates. To check for updates, click Help → Check for Updates.

CHAPTER 3. UPDATING JBOSS DEVELOPER STUDIO INTEGRATION STACK
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CHAPTER 4. INSTALLING JBOSS DEVELOPER STUDIO
INTEGRATION STACK USING THE STANDALONE
INSTALLER

Use the standalone installer to install JBoss Developer Studio Integration Stack with all the latest
versions of the integration stack components:

JBoss Developer Studio

JBoss Fuse & JBoss Fuse Service Works

JBoss Business Rules Management System (BRMS)

JBoss Business Process Management Suite (BPM Suite)

Important

The embeddable version of Xulrunner works with GTK2, but not with GTK3. As a result,
the SWT (Standard Widget Toolkit) Browser, which is used for documentation in JBoss
Fuse tooling and Javadocs in the Java Editor, does not work.

The workaround for this issue is to install WebKitGTK when using GTK3. An additional
workaround is to enable GTK2 and use it instead of GTK3. Note that the browser widget
does not work with Red Hat Enterprise Linux 7 or supported Fedora version because they
do not have WebKitGTK installed by default.

Further information on what SWT Browser does in Eclipse is available here:
https://www.eclipse.org/swt/faq.php#browserlinux

To install JBoss Developer Studio Integration Stack using the Standalone Installer:

1. Download the JBoss Developer Studio Integration Stack Standalone Installer file from Red
Hat JBoss Developer Studio Integration Stack Software Downloads and run the file.

2. Agree to the terms and conditions and specify a target installation directory and a target JDK
for the installation.

3. Select the required components from the Select Additional Features to Install
screen:

Figure 4.1. Select Additional Features to Install

Red Hat JBoss Developer Studio Integration Stack 10.0 Installation Guide
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4. Click Next to continue the installation process until the process completes.

When complete, JBoss Developer Studio Integration Stack and the integration stack components
are ready to use.
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CHAPTER 5. INSTALLING JBOSS DEVELOPER STUDIO
INTEGRATION STACK IN ECLIPSE WHEN ONLINE

JBoss Developer Studio Integration Stack is available to install in Eclipse when you are online.
Installing these components also installs JBoss Developer Studio 10.0.

To install JBoss Developer Studio Integration Stack in Eclipse when online:

1. Start Eclipse Neon for Java EE Developers.

2. Click Help → Eclipse Marketplace, locate Red Hat JBoss Developer Studio Integration
Stack and click Install.

3. Select the components that you want to install.

a. For JBoss Fuse, select JBoss Fuse Development (Fuse tooling related to
Camel route development).

b. For JBoss BRMS and JBoss BPM Suite, select JBoss Business and Rules
Development (BPEL, BPMN2, jBPM, Drools).

c. For JBoss Fuse Service Works, select JBoss Integration and SOA Development.

d. For JBoss Data Virtualization, which is Early Access for version 10.0:

i. Install any JBoss Developer Studio or JBoss Developer Studio
Integration Stack component from the Eclipse Marketplace (as instructed in
step 2).

ii. Click Help → Red Hat Central.

iii. In the Red Hat Central tab, click the Software/Install tab at the bottom.

iv. Check the Enable Early Access check box.

v. In the list of components, check the Boss Data Virtualization
Development (Teiid Designer) option and click Install/Update.

4. Follow the on-screen instructions to complete the installation process.

During the installation process, warnings about installing unsigned content may display. If this is the
case, review the details of the content and if satisfied click OK to continue with the installation.

Red Hat JBoss Developer Studio Integration Stack 10.0 Installation Guide
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Important

The embeddable version of Xulrunner works with GTK2, but not with GTK3. As a result,
the SWT (Standard Widget Toolkit) Browser, which is used for documentation in JBoss
Fuse tooling and Javadocs in the Java Editor, does not work.

The workaround for this issue is to install WebKitGTK when using GTK3. An additional
workaround is to enable GTK2 and use it instead of GTK3. Note that the browser widget
does not work with Red Hat Enterprise Linux 7 or supported Fedora version because they
do not have WebKitGTK installed by default.

Further information on what SWT Browser does in Eclipse is available here:
https://www.eclipse.org/swt/faq.php#browserlinux

Once installed, complete the additional configuration actions before you can use the
JBoss Developer Studio Integration Stack functionality. For plug-in specific configuration
information, see the appropriate Red Hat JBoss product documentation available from the Red Hat
Customer Portal.

Warning

Restart the IDE to apply the changes. Until it is restarted, the changes may make the
IDE unstable.

CHAPTER 5. INSTALLING JBOSS DEVELOPER STUDIO INTEGRATION STACK IN ECLIPSE WHEN ONLINE
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CHAPTER 6. INSTALLING JBOSS DEVELOPER STUDIO
INTEGRATION STACK IN ECLIPSE WHEN OFFLINE

To install JBoss Developer Studio Integration Stack in Eclipse when offline:

1. Locate and download the following files:

a. Red Hat JBoss Developer Studio 10.1.0.GA Update Site Zip file from
https://devstudio.redhat.com/10.0/stable/updates/.

b. Red Hat JBoss Developer Studio Integration Stack 10.0.0.GA Update Site Zip
file from https://devstudio.redhat.com/10.0/stable/updates/integration-stack/.

c. (Optional, required only for Early Access components) Red Hat JBoss Developer
Studio Integration Stack 10.0.0.GA Update Site Early Access Zip file from
https://devstudio.redhat.com/10.0/stable/updates/integration-stack/.

2. Start Eclipse Neon for Java EE Developers.

3. Click Window → Preferences → Install/Update → Available Software Sites.

4. Click Add, click Archive to locate the JBoss Developer Studio Update .zip file, select the
file and click OK.

5. (Optional, required only for Early Access components) Click Add, click Archive to locate the
Early Access .zip file, select the file and click OK.

6. Click OK again to close the Preferences window.

7. Click Help → Install New Software.

8. Next to the Work with field, click Add and click Archive to locate the Red Hat JBoss
Developer Studio Integration Stack 10.0.0.GA Update Site Zip file.

9. From the table of categories, select the JBoss Developer Studio Integration Stack
functionality you want to install:

a. For JBoss Fuse, select JBoss Fuse Development.

b. For JBoss BRMS and JBoss BPM Suite, select JBoss Business and Rules
Development.

c. For JBoss Fuse Service Works, select JBoss Integration and SOA Development.

d. For JBoss Data Virtualization (Early Access):

i. Ensure that the optional Red Hat JBoss Developer Studio Integration
Stack 10.0.0.GA Update Site Early Access Zip is selected.

ii. Select JBoss Data Virtualization Development.

10. Click Next.

11. Follow the on-screen instructions to complete the installation process.

Red Hat JBoss Developer Studio Integration Stack 10.0 Installation Guide
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During the installation process, you may receive warnings about installing unsigned content. If this is
the case, review the details of the content and if satisfied click OK to continue with the installation.

Once installation is complete, you are prompted to restart the IDE. Click Yes when any changes to
open projects are saved and you are ready to restart the IDE immediately.

Important

The embeddable version of Xulrunner works with GTK2, but not with GTK3. As a result,
the SWT (Standard Widget Toolkit) Browser, which is used for documentation in JBoss
Fuse tooling and Javadocs in the Java Editor, does not work.

The workaround for this issue is to install WebKitGTK when using GTK3. An additional
workaround is to enable GTK2 and use it instead of GTK3. Note that the browser widget
does not work with Red Hat Enterprise Linux 7 or supported Fedora version because they
do not have WebKitGTK installed by default.

Further information on what SWT Browser does in Eclipse is available here:
https://www.eclipse.org/swt/faq.php#browserlinux

Warning

Restart the IDE to apply the changes. Until it is restarted, the changes may make the
IDE unstable.

CHAPTER 6. INSTALLING JBOSS DEVELOPER STUDIO INTEGRATION STACK IN ECLIPSE WHEN OFFLINE
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CHAPTER 7. INSTALLING JBOSS DEVELOPER STUDIO
INTEGRATION STACK IN JBOSS DEVELOPER STUDIO
WHEN ONLINE

JBoss Developer Studio Integration Stack is available to install from JBoss Developer Studio,
through Red Hat Central Software/Update tab, when online.

Important

To install JBoss Developer Studio Integration Stack as detailed in the steps below, it is
essential that you have an instance of JBoss Developer Studio installed. For detailed
steps to install JBoss Developer Studio see Install Red Hat JBoss Developer Studio.

To install JBoss Developer Studio Integration Stack in JBoss Developer Studio when online,
complete the following steps:

1. Start JBoss Developer Studio 10.1.

2. In Red Hat Central, click the Software/Update tab. If Red Hat Central is not visible, click
Window → Red Hat Central.

3. In the list of available software, locate JBoss Developer Studio Integration Stack.

4. Select the check boxes corresponding to the JBoss Developer Studio Integration Stack
functionality you want to install:

a. For JBoss Fuse, select JBoss Fuse Development.

b. For JBoss BRMS and JBoss BPM Suite, select JBoss Business and Rules
Development.

c. For JBoss Fuse Service Works, select JBoss Integration and SOA Development.

d. For JBoss Data Virtualization:

i. Ensure that the Early Access check box is selected to view Early Access
components.

ii. Select JBoss Data Virtualization Development.

5. Click Install/Update.

6. Follow the on-screen instructions to complete the installation process.

Restart the IDE to apply the changes. Until it is restarted, the changes may make the IDE unstable.

Red Hat JBoss Developer Studio Integration Stack 10.0 Installation Guide
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Important

The embeddable version of Xulrunner works with GTK2, but not with GTK3. As a result,
the SWT (Standard Widget Toolkit) Browser, which is used for documentation in JBoss
Fuse tooling and Javadocs in the Java Editor, does not work.

The workaround for this issue is to install WebKitGTK when using GTK3. An additional
workaround is to enable GTK2 and use it instead of GTK3. Note that the browser widget
does not work with Red Hat Enterprise Linux 7 or supported Fedora version because they
do not have WebKitGTK installed by default.

Further information on what SWT Browser does in Eclipse is available here:
https://www.eclipse.org/swt/faq.php#browserlinux.

Once installed, you may need to complete additional configuration actions before you can use the
JBoss Developer Studio Integration Stack functionality. For plug-in specific configuration
information, see the appropriate Red Hat JBoss product documentation available from the Red Hat
Customer Portal.

Important

If you choose to install only selected functionality of a JBoss Developer Studio
Integration Stack category, then the category continues to be listed as uninstalled in the
JBoss Central Software/Update tab.

CHAPTER 7. INSTALLING JBOSS DEVELOPER STUDIO INTEGRATION STACK IN JBOSS DEVELOPER STUDIO WHEN ONLINE
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CHAPTER 8. INSTALLING JBOSS DEVELOPER STUDIO
INTEGRATION STACK IN JBOSS DEVELOPER STUDIO
WHEN OFFLINE

Important

To install JBoss Developer Studio Integration Stack as detailed in the steps below, it is
essential that you have an instance of JBoss Developer Studio installed. For detailed
steps to install JBoss Developer Studio see Install Red Hat JBoss Developer Studio.

To install JBoss Developer Studio Integration Stack in JBoss Developer Studio when offline:

1. Locate and download the Red Hat JBoss Developer Studio Integration Stack 10.0.0.GA
Update Site Zip file from https://devstudio.redhat.com/10.0/stable/updates/integration-
stack/.

2. (Optional, required only for Early Access components) Locate and download the Red Hat
JBoss Developer Studio Integration Stack 10.0.0.GA Update Site Early Access Zip file
from https://devstudio.redhat.com/10.0/stable/updates/integration-stack/.

3. Start JBoss Developer Studio 10.1.

4. Click Help → Install New Software.

5. Next to the Work with field, click Add and click Archive to locate the Red Hat JBoss
Developer Studio Integration Stack 10.0.0.GA Update Site Zip file.

6. (Optional, required only for Early Access components) Next to the Work with field, click
Add and click Archive to locate the Red Hat JBoss Developer Studio Integration
Stack 10.0.0.GA Update Site Early Access Zip file.

7. From the table of categories, select the JBoss Developer Studio Integration Stack
functionality you want to install:

a. For JBoss Fuse, select JBoss Fuse Development.

b. For JBoss BRMS and JBoss BPM Suite, select JBoss Business and Rules
Development.

c. For JBoss Fuse Service Works, select JBoss Integration and SOA Development.

d. For JBoss Data Virtualization, select JBoss Data Virtualization Development
(Early Access).

8. Click Next.

9. Follow the on-screen instructions to complete the installation process.

During the installation process, you may receive warnings about installing unsigned content. If this is
the case, review the details of the content and if satisfied click OK to continue with the installation.
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Important

The embeddable version of Xulrunner works with GTK2, but not with GTK3. As a result,
the SWT (Standard Widget Toolkit) Browser, which is used for documentation in JBoss
Fuse tooling and Javadocs in the Java Editor, does not work.

The workaround for this issue is to install WebKitGTK when using GTK3. An additional
workaround is to enable GTK2 and use it instead of GTK3. Note that the browser widget
does not work with Red Hat Enterprise Linux 7 or supported Fedora version because they
do not have WebKitGTK installed by default.

Further information on what SWT Browser does in Eclipse is available here:
https://www.eclipse.org/swt/faq.php#browserlinux

Once installation is complete, you are prompted to restart the IDE. Click Yes when any changes to
open projects are saved and you are ready to restart the IDE immediately.

Warning

The IDE changes do not take effect until the IDE is restarted and the IDE may be
unstable until it is restarted.
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CHAPTER 9. UNINSTALLATION OPTIONS

After concluding development in one of the Red Hat JBoss Developer Studio Integration Stack
tooling plug-ins, you can choose to uninstall either an entire category of plug-ins, or individual plug-
ins. Removing one or more plug-ins that are no longer required provides continued stability and
ensures optimal performance due to a smaller memory footprint. Uninstall a category of features to
remove all related features efficiently, or select individual plug-ins to remove in a customized
uninstall process.

To uninstall an entire category of features, see Section 9.1, “Uninstalling an Entire Category of
JBoss Developer Studio Integration Stack”.

To uninstall a single feature, see Section 9.2, “Uninstalling a Single Feature of
JBoss Developer Studio Integration Stack”.

9.1. UNINSTALLING AN ENTIRE CATEGORY OF
JBOSS DEVELOPER STUDIO INTEGRATION STACK

To uninstall an entire category of JBoss Developer Studio Integration Stack:

1. In Red Hat Central, click the Software/Update tab.

Note

If Red Hat Central is not visible, click Window → Red Hat Central.

2. Click the Show installed check box.

3. In the Features Available list, locate JBoss Developer Studio Integration Stack.

4. Select the check boxes corresponding to the JBoss Developer Studio Integration Stack
category to uninstall:

a. For JBoss Fuse, select JBoss Fuse Development.

b. For JBoss BRMS and JBoss BPM Suite, select JBoss Business and Rules
Development.

c. For JBoss Fuse Service Works, select JBoss Integration and SOA Development.

d. For JBoss Data Virtualization, select JBoss Data Virtualization Development.

5. Click Uninstall.

6. Follow the on-screen instructions to complete the process of uninstalling the selected
category.

7. Restart the IDE to implement the changes. An immediate restart is recommended because
the IDE may be unstable until a restart.

9.2. UNINSTALLING A SINGLE FEATURE OF
JBOSS DEVELOPER STUDIO INTEGRATION STACK

Red Hat JBoss Developer Studio Integration Stack 10.0 Installation Guide
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To uninstall a single feature of JBoss Developer Studio Integration Stack:

1. Click Help → Installation Details.

2. In the search field type the feature to uninstall.

3. Click the feature to uninstall and click Uninstall.

Note

To delete more than one feature select the features while you press the Shift key.

4. Follow the on-screen instructions to complete the process of uninstalling the selected
feature.

5. Restart the IDE to implement the changes. An immediate restart is recommended because
the IDE may be unstable until a restart.
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