Menu Close

4.8.3. 将软件包限制为特定的 Perl 版本

要将软件包限制为特定的 Perl 版本,请按照以下步骤执行:

步骤

  • 使用 RPM SPEC 文件中的 perl(:VERSION) 依赖项与所需的版本约束:

    例如,要将软件包限制为 Perl 版本 5.30 及更高版本,请使用:

    BuildRequires: perl(:VERSION) >= 5.30
警告

不要使用与 perl 软件包版本的比较,因为它会包括 epoch 号。