10.11. 编译器和开发工具

GCC Toolset 10:Valgrind 错误报告了对 IBM z15 架构的支持

Valgrind 尚不支持某些 IBM z15 处理器功能,但 GCC Toolset 10 Valgrind 中的一个错误会导致它在 z15 支持的系统上运行时报告对 z15 的支持。因此,尝试使用 z15 功能的软件无法在 Valgrind 下运行。要临时解决这个问题,在 z15 处理器中运行时,使用通过 /usr/bin/valgrind 访问的 Valgrind 系统版本。此构建将不会报告 z15 的支持。

BZ#1937340

PCP 中的 pmproxy 内存泄漏

pmproxy 服务在Co-Pilot(PCP)5.3.0之前的版本中会遇到内存泄漏的问题。 。在 RHEL 8.4 以及 RHEL 8 的早期小版本中,PCP 版本 5.3.0 不可用。因此,RHEL 8 用户可能会遇到比预期更高的内存使用率。

要临时解决这个问题,请限制 pmproxy 的内存使用率:

  1. 通过执行以下命令来创建 /etc/systemd/system/pmproxy.service.d/override.conf 文件:

    # systemctl edit pmproxy
  2. override.conf 中添加以下内容并保存修改:

    [Service]
    MemoryMax=10G

    根据您的需求替换 10G 值。

  3. 重启 pmproxy 服务:

    # systemctl restart pmproxy

因此,如果 pmproxy 的内存使用率达到了给定的限制,pmproxy 服务会被重启。

(BZ#1991659)