7.6. 动态编程语言,Web和数据库服务器 (机器翻译版本)

数据库服务器不能并行安装

mariadbmysql 由于RPM软件包冲突,因此无法在RHEL 8.0中并行安装模块。

按照设计,不可能并行安装同一模块的多个版本(流)。例如,您只需要从中选择一个可用的流 postgresql 模块,或者 10 (默认)或 9.6。RHEL 6和RHEL 7的Red Hat软件集合中可以并行安装组件。在RHEL 8中,可以在容器中使用不同版本的数据库服务器。

(BZ#1566048)

问题在于 mod_cgid 记录

如果 mod_cgid Apache httpd模块在线程多处理模块(MPM)下使用,这是RHEL 8中的默认情况,发生以下日志记录问题:

  • stderr CGI脚本的输出没有标准时间戳信息的前缀。
  • stderr CGI脚本的输出未正确重定向到特定于的日志文件 VirtualHost, ,如果配置。

(BZ#1633224)

IO::Socket::SSL Perl模块不支持TLS 1.3

在RHEL 8中实现了TLS 1.3协议的新功能,例如会话恢复或握手后身份验证 OpenSSL 图书馆但不在 Net::SSLeay Perl模块,因此在不可用 IO::Socket::SSL Perl模块。因此,客户端证书身份验证可能会失败,并且重新建立会话可能比使用TLS 1.2协议慢。

要解决此问题,请通过设置禁用TLS 1.3的使用 SSL_version 选项 !TLSv1_3 创建时的值 IO::Socket::SSL 宾语。

(BZ#1632600)


为了尽快向用户提供最新的信息,本文档可能会包括由机器自动从英文原文翻译的内容。如需更多信息,请参阅此说明。