Red Hat Training

A Red Hat training course is available for Red Hat Enterprise Linux

4.14. PostgreSQL

4.14.1. 升级数据库

如果您要从现在正在使用 PostgreSQL 8.4(postgresql84-* 软件包)的红帽企业版 Linux 5 安装升级,红帽企业版 Linux 6 PostgreSQL 软件包将作为简易替代者进行操作。
但是,如果您是从使用 PostgreSQL 8.1(postgresql-* 软件包)或者更早版本的红帽企业版 Linux 5 安装升级,则您需要保留现有数据库。您将需要按照以下转储和重新载入过程,因为数据格式有变化:http://www.postgresql.org/docs/8.4/interactive/install-upgrading.html。请确定您在升级到红帽企业版 Linux 6“之前 ”执行该转储步骤。