Menu Close

3.2.5. 安装 Operator 的特定版本

您可以通过在 Subscription 对象中设置集群服务版本(CSV)来安装 Operator 的特定版本。

先决条件

  • 使用具有 Operator 安装权限的账户访问 OpenShift Container Platform 集群
  • 已安装 OpenShift CLI(oc

流程

  1. 通过设置 startingCSV 字段,创建一个 Subscription 对象 YAML 文件,向带有特定版本的 Operator 订阅一个命名空间。将 installPlanApproval 字段设置为 Manual,以便在目录中存在更新的版本时防止 Operator 自动升级。

    例如,可以使用以下 sub.yaml 文件安装 Red Hat Quay Operator,专门用于版本 3.4.0:

    带有特定起始 Operator 版本的订阅

    apiVersion: operators.coreos.com/v1alpha1
    kind: Subscription
    metadata:
      name: quay-operator
      namespace: quay
    spec:
      channel: quay-v3.4
      installPlanApproval: Manual 1
      name: quay-operator
      source: redhat-operators
      sourceNamespace: openshift-marketplace
      startingCSV: quay-operator.v3.4.0 2

    1
    如果您指定的版本会被目录中的更新版本取代,则将批准策略设置为 Manual。此计划阻止自动升级到更新的版本,且需要在启动 CSV 可以完成安装前手动批准。
    2
    设置 Operator CSV 的特定版本。
  2. 创建 Subscription 对象:

    $ oc apply -f sub.yaml
  3. 手动批准待处理的安装计划以完成 Operator 安装。