Menu Close

4.5.2.4.2. 准备 Operator 以使用支持的镜像

在 OpenShift Container Platform 上运行基于 Helm 的 Operator 之前,请将项目更新为使用支持的镜像。

流程

  1. 更新项目根级别 Dockerfile 以使用支持的镜像。更改默认构建器镜像引用:

    FROM quay.io/operator-framework/helm-operator:v1.3.0

    改为:

    FROM registry.redhat.io/openshift4/ose-helm-operator:v4.7
    重要

    使用与 Operator SDK 版本匹配的构建器镜像版本。因项目布局或 scaffolding 而导致问题,特别是将较新的 Operator SDK 版本与下游 OpenShift Container Platform 构建器镜像混合时。

  2. config/default/manager_auth_proxy_patch.yaml 文件中,修改 image 值:

    gcr.io/kubebuilder/kube-rbac-proxy:<tag>

    使用支持的镜像:

    registry.redhat.io/openshift4/ose-kube-rbac-proxy:v4.7