1.2.11.5. 已知问题

  • 带有 ruby-kafka-1.1.0fluent-plugin-kafka-0.13.1 gems 的 Fluentd pod 与 Apache Kafka 版本 0.10.1.0 不兼容。

    因此,日志转发到 Kafka 会失败并显示消息: error_class=Kafka::DeliveryFailed error="Failed to send messages to flux-openshift-v4/1"

    ruby-kafka-0.7 gem 丢弃了对 Kafka 0.10 的支持,替代了对 Kafka 0.11 的原生支持。ruby-kafka-1.0.0 gem 添加了对 Kafka 2.3 和 2.4 的支持。当前的 OpenShift Logging 版本测试并支持 Kafka 版本 2.4.1。

    要临时解决这个问题,升级到受支持的 Apache Kafka 版本。

    (BZ#1907370)