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Abstract

Information for users installing Red Hat Developer Studio. This guide describes all prerequisites for
a successful installation of the product followed by a number of installation methods, including how
to use your existing installation of Eclipse.
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PART I. INSTALLATION GUIDE FOR DEVELOPER STUDIO
This guide details steps to install, uninstall, and upgrade Developer Studio that you may have installed
using different methods.

Prerequisites

Developer Studio 12.9 is supported for use with a range of operating systems, architecture, and Java
developer kit combinations; for a complete list, see https://access.redhat.com/documentation/en-
us/red_hat_developer_studio/12.9/html/supported_configurations_and_components/index on the
Red Hat Customer Portal.

NOTE

If you install Developer Studio on Windows in a folder accessible to all the users
(example: c:\devstudio), this DevStudio instance can be used by all the users. However, if
the main installation folder is not writable by a given user, any newly installed feature and
update gets saved inside the user’s home directory.

Minimum hardware requirements

1. 4 GB RAM (minimum 2 GB RAM)

2. 2 GB hard disk space

Software requirements

1. Install OpenJDK. Red Hat OpenJDK is recommended.

INSTALLING OPENJDK 1.8.0 ON WINDOWS
To install OpenJDK 1.8.0 on Windows using the MSI-based installer:

1. Download the MSI-based installer from:
http://developers.redhat.com/products/openjdk/overview/.

2. Run the installer and follow the on-screen instructions to install.

3. To configure Developer Studio to use OpenJDK, follow the instructions at Working with JREs.

INSTALLING OPENJDK 1.8.0 ON RHEL
To install OpenJDK 1.8.0 on Red Hat Enterprise Linux:

NOTE

All the commands in the following procedure must be run as the root user.

1. Register and subscribe the system by running the following command:

# subscription-manager register

2. When prompted, enter your Red Hat Customer Portal username and password.

3. To find a suitable subscription, such as Developer Subscription, run the following command:

# subscription-manager list --available
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This command lists the available subscriptions and details of the subscriptions. Note down the
pool ID of the appropriate subscription.

4. To attach a subscription to your system, run the following command:

# subscription-manager attach --pool=<pool ID from previous command>

5. To install OpenJDK RPMs:

# yum install java-1.8.0-openjdk-devel

NOTE

Install the java-1.8.0-openjdk-demo package for examples of Java applications and the
java-1.8.0-openjdk-src package to debug your applications. Both packages are available
from the Optional repository. Use the following command to enable that repository on your
system:

# subscription-manager repos --enable=rhel-7-server-optional-
rpms

Substitute the version number in the above command with 6 if you use Red Hat
Enterprise Linux 6.

Use the following command to install the packages:

# yum install java-1.8.0-openjdk-src java-1.8.0-openjdk-demo
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CHAPTER 1. INSTALLING DEVELOPER STUDIO IN ECLIPSE
Developer Studio for Eclipse packages the Developer Studio plug-ins for your existing Eclipse instance.
You can either install Developer Studio from the Eclipse Marketplace when you are online or use the 
Update Site Zip to install it when you are offline.

1.1. INSTALLING DEVELOPER STUDIO IN ECLIPSE WHEN ONLINE

Developer Studio is available to install from Eclipse Marketplace when you are online.

IMPORTANT

If anytime before or during the installation, you are asked about selecting additional
features to install, you may select Fuse Tooling to use the Fuse tooling features after the
installation is complete.

Procedure

To install Developer Studio BYOE from Eclipse Marketplace, take the following steps:

1. Start Eclipse SimRel 2018-09 GA.

2. Click Help > Eclipse Marketplace, locate Red Hat Developer Studio 12.9 GA, and click
Install.

3. Follow the on-screen instructions to complete the installation process.

During the installation process, if you receive warnings about installing unsigned content, review the
details of the content and if satisfied, click OK to continue with the installation.

After the installation is complete, you are prompted to restart Eclipse. Click Yes to restart immediately
and No if you need to save any unsaved changes to open projects. Note that the IDE changes do not
take effect until Eclipse is restarted.

1.2. INSTALLING DEVELOPER STUDIO IN ECLIPSE WHEN OFFLINE

You need the Update Site Zip to install Developer Studio in Eclipse in the offline mode. Alternatively,
you can also use an installer downloaded on your system instead of the Update Site Zip to install
Developer Studio in Eclipse when Offline. Note that the Target Platform Zip contains the features
on which DevStudio depends. It also contains the sources of all the included plugins. You can download
the Target Platform Zip from https://devstudio.redhat.com/12/stable/updates/.

IMPORTANT

You must first be online to download the .zip file before proceeding to install
Developer Studio in Eclipse in the offline mode.

If anytime before or during the installation, you are asked about selecting
additional features to install, you may select Fuse Tooling to use the Fuse tooling
features after the installation is complete.

Procedure

To install Developer Studio in Eclipse in offline mode, take the following steps:

CHAPTER 1. INSTALLING DEVELOPER STUDIO IN ECLIPSE
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1. Download the Red Hat Developer Studio 12.9 Update Site Zip from
https://devstudio.redhat.com/12/stable/updates/.

2. Start Eclipse SimRel 2018-09 GA.

3. Click Help > Install New Software.

4. In the Work with field, enter the path of the Update Site Zip file. Alternatively, click Add and
click Archive to locate the file.

5. From the table of components, select Red Hat Developer Studio 12 - Bring Your Own
Eclipse and click Next.

6. Follow the on-screen instructions to complete the installation process.

During the installation process, you may receive warnings about installing unsigned content. If this is the
case, review the details of the content and if satisfied, click OK to continue with the installation.

After the installation is complete, you are prompted to restart Eclipse. Click Yes to restart immediately
and No to save any unsaved changes to open projects. Note that the IDE changes do not take effect
until Eclipse is restarted.
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CHAPTER 2. INSTALLING DEVELOPER STUDIO STAND-
ALONE USING THE INSTALLER

Developer Studio stand-alone packages the Developer Studio plug-ins with Eclipse and dependent third-
party plug-ins in an installer for all operating systems.

The installer provided to install Developer Studio stand-alone is available from a variety of sources,
including the Red Hat Customer Portal.

IMPORTANT

If anytime before or during the installation, you are asked about selecting additional
features to install, you may select Fuse Tooling to use the Fuse tooling features after the
installation is complete.

Procedure

To install Developer Studio stand-alone, take the following steps:

1. Download Red Hat Developer Studio 12.9 Stand-alone Installer from Developer Studio
Software Downloads.

2. Start the installer:

$ cd /path/to/.jar
$ java -jar devstudio-12.9.0.GA-installer-standalone.jar

Alternatively, you can start the installer by double-clicking the .jar file. On OS X systems, hold
control and click the .jar file, click Open, review the .jar file details and if satisfied, click
Open.

3. Follow the on-screen instructions to complete the installation process.

CHAPTER 2. INSTALLING DEVELOPER STUDIO STAND-ALONE USING THE INSTALLER
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CHAPTER 3. PERFORMING ADVANCED INSTALLATION
TASKS

This section describes steps to install Developer Studio using a script and to build the Red Hat Developer
Studio installer from the source code.

3.1. INSTALLING RED HAT DEVELOPER STUDIO USING A SCRIPT

Use the scripted method to install Developer Studio stand-alone using the GUI once and then a
generated script for subsequent installations. This installation method enables simplified repeat
installations or installations in bulk without stepping through the installer GUI for every installation.

The Developer Studio stand-alone installer is available from a variety of sources, including the Red Hat
Customer Portal.

Procedure

To install Developer Studio by script, take the following steps:

1. Download Red Hat Developer Studio 12.9 Stand-alone Installer from Developer Studio
Software Downloads.

2. Start the installer:

$ cd /path/to/.jar
$ java -jar devstudio-12.9.0.GA-installer-standalone.jar

3. Follow the on-screen instructions to complete the installation process. After the installation is
complete, an InstallConfigRecord.xml file is generated in the Developer Studio
installation directory.

4. In the terminal window, enter the following command:

$ java -jar devstudio-12.9.0.GA-installer-standalone.jar \
  /path/to/devstudio/InstallConfigRecord.xml

NOTE

The generated InstallConfigRecord.xml file is machine-specific and uses the Java
Developer Kit and installation paths of your system. To use the 
InstallConfigRecord.xml file for other operating systems, Java Developer Kits, or
paths, you must manually modify the file.

3.2. BUILDING THE DEVELOPER STUDIO STAND-ALONE INSTALLER
FROM SOURCE

Prerequisites

Maven 3.3 or later, with Java 8 must be installed to build the installer from the source code. To
obtain and configure Maven, see http://maven.apache.org/.

Procedure

Red Hat Developer Studio 12.9 Installation Guide
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To build the Developer Studio stand-alone installer from source, take the following steps:

1. Clone the git repository by running the command:

$ git clone https://github.com/jbdevstudio/jbdevstudio-product.git

2. Checkout the master branch by running the command:

$ git checkout master

3. Build the installer by following the instructions in the jbdevstudio-product/README.adoc file.

NOTE

The jbdevstudio-product/README.adoc file is located in the extracted current
folder at the highest level.

Building takes some time to complete, after which the devstudio-[version]-installer-
standalone.jar file will be located in the /path/to/jbdevstudio-product/installer/target
directory.
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CHAPTER 4. UNINSTALLING DEVELOPER STUDIO
You may want to uninstall a specific version of Developer Studio if you have concluded development in
one version, say 11.x, and you now want to install a newer version, say 12.x. However, you can have
more than one version of Installer-installed Developer Studio or Eclipse-installed Developer Studio on
your system, provided you have these versions located in different directories.

4.1. UNINSTALLING DEVELOPER STUDIO INSTALLED USING THE
INSTALLER

Procedure

To uninstall Developer Studio, take the following steps:

1. Ensure that Developer Studio is not running.

2. On the command line, navigate to path/to/Developer Studio/Uninstaller.

3. On the command line, type:

$ java -jar uninstaller.jar

4. In the IzPack Uninstaller dialog box:

a. Click the Force the deletion of <path_to_Developer Studio_directory> check box, to
remove the entire Developer Studio installation directory. If this is not selected, Red Hat
Developer Studio will be uninstalled but some files will be left as is in the installation
directory.

b. Click Uninstall.

5. After the progress bar shows Finished, click Quit to close the Uninstaller dialog box.

Figure 4.1. Uninstall Developer Studio
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4.2. UNINSTALLING RED HAT DEVELOPER STUDIO INSTALLED IN
ECLIPSE

Procedure

Developer Studio can be uninstalled using the following steps regardless of whether it was installed via
Eclipse Marketplace or the update .zip file.

To uninstall Developer Studio, take the following steps:

1. Start Eclipse SimRel 2018-09 GA.

2. Click Help > Eclipse Marketplace.

3. In the Eclipse Marketplace window, Find field, type Red Hat Developer Studio and then click
Go.

4. Click Installed in the Red Hat Developer Studio <version> section.

5. Click the Update drop-down list to view the options available. Click Uninstall.

Figure 4.2. Uninstall Button

6. In the Confirm Selected Features window, ensure that Red Hat Developer Studio <version>
is selected and click Confirm.

7. Click Finish.

CHAPTER 4. UNINSTALLING DEVELOPER STUDIO
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Figure 4.3. Confirm Selected Feature Deletion

8. In the Software Updates dialog box, click Yes to restart Eclipse for the changes to take effect.
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CHAPTER 5. UPGRADING DEVELOPER STUDIO
Depending on your need, refer to the respective sections to upgrade Developer Studio.

5.1. UPGRADING MAJOR VERSIONS OF DEVELOPER STUDIO

Each major version of Developer Studio is based on a different version of Eclipse. As a result, it is not
possible to update an older major version of Developer Studio to a newer major version. For example, it
is not possible to update a devstudio 10.x installation to 11.x, nor is it possible to update a 11.x
installation to 12.x. However, it is possible to use the workspaces created using Developer Studio 11.x
with Developer Studio 12.x.

The following table details the version of Eclipse supported with each major version of Red Hat
Developer Studio:

Table 5.1. Eclipse Version Support Matrix

Red Hat Developer Studio Version Base Eclipse Version

Developer Studio 12.9 Eclipse SimRel 2018-09 GA

Developer Studio 12.0 Eclipse 4.8 (Photon)

Developer Studio 11.x Eclipse 4.7 (Oxygen)

Red Hat Developer Studio 10.x Eclipse 4.6 (Neon)

Red Hat Developer Studio 9.x Eclipse 4.5 (Mars)

5.2. UPDATING MINOR VERSIONS OF RED HAT DEVELOPER STUDIO

You can update your Red Hat Developer Studio to the latest minor versions within the major release. For
example, you can update your Red Hat Developer Studio 12.0 installation to 12.9.

IMPORTANT

Before updating, back up your workspace. In addition to your project files, your workspace
contains metadata about customized settings and preferences for the IDE. To back up
your workspace, either copy the workspace directory to a backup location, or save it as a
compressed file.

You may be automatically notified by the IDE when the Red Hat Developer Studio 12.y update is
available, depending on your IDE settings for automatic updates.

Procedure

Alternatively, use the following instructions to manually check for and apply the most recent Red Hat
Developer Studio update:

1. In the IDE, click Window > Preferences, expand Install/Update and click Available Software
Sites.

CHAPTER 5. UPGRADING DEVELOPER STUDIO
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2. In the Available Software Sites table, ensure the URL
https://devstudio.redhat.com/12/stable/updates/ is listed or, if not listed, add it.

3. Close the Preferences window.

4. Click Help > Check for Updates.

5. For any Red Hat Developer Studio updates found, follow the on-screen instructions to apply the
update.

During the update process, you may receive warnings about installing unsigned content. If this is the
case, review the details of the content and if satisfied click OK to continue with the update.

After updating is complete, you are prompted to restart the IDE. Click Yes to restart immediately or No to
save any unsaved changes to open projects. Note that IDE changes do not take effect until the IDE is
restarted.

Red Hat Developer Studio 12.9 Installation Guide
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CHAPTER 6. REPORTING ISSUES FROM WITHIN RED HAT
DEVELOPER STUDIO

Red Hat Developer Studio and JBoss Tools allow you to report issues as they are encountered from
within the IDE. It is recommended that you report issues frequently and include as much detail as
possible to help the development and testing teams replicate and fix the issue. When an error, related to
the JBoss Tools plugins occurs, a notification displays in the lower right corner of the IDE. The
notification outlines the error. You can either dismiss, send directly, or provide more details about the
error.

You can also enable error reporting from: Preferences > General > Error Reporting. These menu
options also allow you to adjust error reporting. If enabled, when you encounter a plugin related error, a
pop-up notification describing the error will display. The user can either dismiss or send the error directly,
or provide more details about the error. When submitting the report, you can optionally provide an email
address. You will be contacted on the given email address in case more information about the error is
required. If you do not enter an email address, the report will be anonymous.

Another way to report errors is by raising a ticket in JIRA. You must enter as much detail as possible in
the JIRA ticket to help the team debug the error. You can attach the error log to the JIRAs submitted
against each problem to provide context for the issue.

CHAPTER 6. REPORTING ISSUES FROM WITHIN RED HAT DEVELOPER STUDIO
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