1.2. Программная совместимость

Этот выпуск включает разрешения зависимостей для поддержки работы программ, предназначенных для ранних версий Red Hat Enterprise Linux. Все еще присутствуют ранние версии некоторых библиотек, в основном, для программ C и C++.
Стоит отметить, что в повторном тестировании и сертификации программ для промежуточных выпусков Red Hat Enterprise Linux необходимости нет. Политика совместимости Red Hat Enterprise Linux гарантирует их работоспособность в пределах основного выпуска. Так, например, программы, сертифицированные для Red Hat Enterprise Linux 6.0, будут совместимы с Red Hat Enterprise Linux 6.1 и т.п.
Ниже приведена таблица совместимости.

Таблица 1.1. Библиотеки совместимости

Пакет Описание
compat-db Библиотека совместимости для Berkeley DB (BDB). Berkeley DB — библиотека поддержки баз данных для приложений сервера и клиента. Этот пакет включает различные версии BDB, в том числе и более ранние.
compat-expat1 Expat — поточно-ориентированное средство разбора XML. Обеспечивает совместимость с предыдущими версиями.
compat-glibc glibc — стандартная библиотека языка С, предоставляющая исполняемые библиотеки и обеспечивающая совместимость при компиляции двоичных файлов, требующих наличия предыдущих версий glibc.
compat-libf2c-34 Включает ранние версии общих библиотек Fortran 77, необходимые для выполнения программ Fortran 77.
compat-libgcc-296 Библиотека libgcc 2.96 и объектные файлы для поддержки совместимости с предыдущими версиями GCC.
compat-libgfortran-41 Библиотека Fortran 95 для поддержки совместимости с программами Fortran, скомпилированными с помощью GCC 4.1.x.
compat-libstdc++-295 Обеспечивает совместимость со стандартной библиотекой C++ 2.95.
compat-libstdc++-296 Обеспечивает совместимость со стандартной библиотекой C++ 2.96.
compat-libstdc++-33 Обеспечивает совместимость со стандартной библиотекой C++ 3.3.
compat-libtermcap Обеспечивает совместимость со старыми программами на основе termcap.
compat-openldap OpenLDAP — открытая реализация LDAP (Lightweight Directory Access Protocol). Этот пакет включает предыдущие версии общих библиотек OpenLDAP, которые могут потребоваться для работы некоторых приложений.
openssl098e Предоставляет OpenSSL 0.98e, который необходим для некоторых приложений SSL.