Red Hat Training

A Red Hat training course is available for RHEL 8

4.7.3. Limitando um pacote a uma versão Perl específica

Para limitar seu pacote a uma versão Perl específica, siga este procedimento:

Procedimento

  • Use a dependência perl(:VERSION) com a restrição de versão desejada em seu arquivo SPEC RPM:

    Por exemplo, para limitar um pacote à versão Perl 5.22 e superior, use:

    BuildRequires: perl(:VERSION) >= 5,22
Atenção

Não utilize uma comparação com a versão do pacote perl, pois ele inclui um número de época.